Office for Mac 2016 Enhanced Error Reporting popup

matias101
New Contributor

HI All, trying to deploy and configure Office for Mac latest version (16.15) via JAMF. everytihng works as expected with a couple exceptions. I am using the Disable First Run Settings from rtrouton github and Office Signin helper.

After everything runs and installs and I open office I get the following popup about enhance error reporting.

4d0e0403bd564dfd92de6eaf21b2ba59

I think I have narrowed this down to a plist entry called "kFRETelemtryConsentKey" setting this to True in /Library/Preferences/com.microsoft.excel prevents this from appearing and it seems like you'd have to write this same entry in all Office App Plist files for it to work on all of them.

Setting that key to 1 seems to disable the popup but I cannot tell if Enhanced error reporting is on or off. I am thinking that in conjunction with the "SendAllTelemetryEnabled" plist setting set to False that it should be but I'm not smart enough to know how or where to confirm that πŸ™‚

I cannot find any reference to this new plist setting anywhere on Jamf Nation or Github so I'm guessing this might be new or am I just way off base and missing something obvious in the scripts already provided that I mentioned above?

2 REPLIES 2

willyg
New Contributor

Thanks for noticing this. I have not been able to find anything about this either. You are the only one referencing this from an Enterprise deployment standpoint.

I too have a similar problem. Don't have Jamf, am using k2000 to push installs & creating custom Volume license mac office with https://github.com/maxschlapfer/MacAdminHelpers/tree/master/Office2016PackageBuilder

This pulls latest office patches, uses your volume license package to create a Microsoft signed Office install package with some customization. Am able to set the first run dialog successfully, but not remove this enhanced error reporting screen. I think I can use your fix if you can tell me the exact bash syntax, as I'm not he best at bash. I'd then be able to post a commit to github to help others.

what I'm trying now is adding this at line 200 to my customization script based on your advice:

#$app is the current app, Excel, Powerpoint, ect
/usr/bin/defaults write /Library/Preferecnes/com.microsoft.$app kFRETelemtryConsentKey -bool True

This does not prevent the "Enhanced Error Reporting Screen from appearing on first run. Can you inform me as to what is wrong with this script fragment?

mr_mindless
New Contributor

willyg, you have a mistake in methodology, as well as a couple typos.

this is confirmed working for currently logged in user named "lander"

defaults write /Users/lander/Library/Containers/com.microsoft.Word/Data/Library/Preferences/com.microsoft.Word.plist kFRETelemtryConsentKey -bool True

note the 'containers' path in user prefs, since all Office apps are now sandboxed. key and path typos are fixed.

I have had bad luck when expecting apps to read prefs from /Library, particularly sandboxed apps. Same here:
I tested this command (with typos) fixed and it fails. Strikethrough so hopefully nobody accidentally thinks it'll work if they don't read all the words.
defaults write /Library/Preferences/com.microsoft.Word.plist kFRETelemtryConsentKey -bool True

The same does work for the default user profile as such:

defaults write /System/Library/User Template/English.lproj/Library/Containers/com.microsoft.PowerPoint/Data/Library/Preferences/com.microsoft.PowerPoint.plist kFRETelemetryConsentKey -bool True

Thanks for pointing me to the right keyname.