Onedrive & Monetery 12.3.1

New Contributor


Has anyone had issues with Onedrive and Monetery 12.3.1? We're getting users with errors -


"Onedrive couldn't start - A system component is preventing Onedrive from starting"


After this the user has to try to resync their onedrive at which point they get a error message -


"Onedrive can't sync this folder, please try again"


I've tried this on fresh devices and just get the last error message, tried different versions of onedrive, deployed differently (Mac store, jamf catalog, direct from microsoft etc). It works when not enrolled so it must be something set within Jamf but I can't see what would be causing this.

Tried setting a PPPC to give onedrive full disk access, along with getting the Team Identifiy with Bundle ID's and allowing them. Still the same

There's no fancy scripts for Onedrive, or .plist/schemas to configure it, it's just a straight deployment.

I've also tried with having Firevault disabled, and not having our antivirus (Microsoft Defender) deployed as well.

I do have an open ticket with Jamf Support but have only had one response all week from them.

Does anyone have any advise?


Valued Contributor

There's been a lot going on (last minute by MS) with Ondrive file sync, post macOS 12.3 / kernel extension blocking.
I haven't got stuck into testing yet myself but seen as you are running fresh OS / Onedrive client, you could be hitting a new bug, lots of reading here. Good luck



We have seen the same issue after a reinstall of Office (switched from VPP store apps to the standalone installer) on devices. We've tried uninstalling office, running the bundled onedrive reset etc etc etc. Nothing works. The only way to fix it is to wipe and reinstall the device. But if anyone else has found a way to resolve this without reinstalling the device, I'm interested! :)

Interesting, the only fix i've been able to find is downgrading the macs to 12.0.1, obviously not a ideal solution. Hopefully a fix is released with 12.4 which should be out in the next month or so, just read a post about it already being released to developers.

New Contributor

So, to wrap this up, I had a KEXT configuration profile setup for a VPN application that conflicted with mac os versions above 12.0.1/12.1 . Un scoped the config profile and onedrive kicked back in.