OneDrive "We can't sync your "OneDrive" folder on Monterey

New Contributor III

I've had this issue since about January 2022. It hasn't been a huge issue because I am operating in an enterprise environment with less than 100 Macs. However, we are growing and this is steadily becoming more prevalent. The reason I post this here is because I'm the main point of contact for Jamf, but I'm still fairly new to setup in this environment so I'd love to hear if anyone has suggestions for this issue. Here's what's happening:

I utilize SSO sign-in through Azure AD. Since about 12.2 and later, any new setup of Mac OS (brand new or refreshed) I have not been able to get users signed into their OneDrive app. We launch the app, put in their email, and then it is 'supposed' to go to the SSO splash page, but OneDrive does not go there. It just seems to refresh the page and ask for the email address again. Once you click next, the app does not ask for the password and then asks where the folder should be synced. You select a location, the app thinks for a moment, and then gives the following error:

'We can't sync your "enter organizational folder name here" folder. Sorry, we can't add your "enter organizational folder here" folder right now. Please try again.'

The odd thing is, you CAN sign in, if you had a device that was enrolled before 12.2 and then updated to 12.2 or 12.3.1, you can still sign into OneDrive. For instance, if I sign into OneDrive on my own account on my primary Mac which is running 12.3.1, it works because I obtained the computer when only 12.0.1 was out. If I spin up a new device and it is on 12.3.1, I try to sign in with the same account info, and I get the error. The following is a list of what I've tried:

1. Restarted the devices.

2. Wiped/re-enrolled the devices

3. Changed to various versions of new/old of OneDrive. Tested with a standalone installer and the app from the VPP store. Same effect.

4. Set a pppc to allow permissions to OneDrive when it installs.

5. Installed OneDrive as an admin and standard user

Possibly more, but I definitely don't remember all the steps I've tried. Does anyone have any suggestions or help regarding deploying the OneDrive app? 90% of my environment is comprised of M1 Macs running Monterey. If there is a special way to deploy it, I haven't found it in my research.


Thank you in advance!

Jordan Keller



New Contributor III

Starting macOS 12.3, Apple deprecates Kernel Extensions Used by Dropbox and OneDrive

What version of OneDrive are you deploying on your fleet? If you have not recently updated the version of OneDrive, that may be the issue. 


Microsoft OneDrive Release Notes 

Microsoft Mac Downloads

New Contributor III

Thanks! I know I read somewhere that the deprecation of File on Demand was happening but I wafsn't sure if Apple was planning on re-adding this feature in some way. This really creates a problem in my environment, but I suppose my users will have to work with the web app from here. The version of OneDrive that I'm using is 22.065.0412.

The sync issue itself we are working on (we believe we have discovered an MFA issue in our Azure environment) so that should at least help.  Thanks for the input!

New Contributor III

Also, Arnold or anyone who sees this, do we know if Apple or Microsoft is planning on making a fix to files-on-demand in the future or is this a 'it's broken now and we don't plan to fix it' situation? Any rumors out there or is the solution simply to sync the whole OneDrive/Sharepoint folder.

New Contributor III

Hey everyone! I figured it out!! We had a bad PPPC file that was blocking a necessary kernel extension somehow. It was a Zoom profile. Check your Configs if you run into this and make sure they aren't the issue, even if its not related to the processes having trouble.

What is the PPPC setting that was preventing Onedrive from starting?