Policies contain invalid references to /usr/sbin/jamf

simon_heers
New Contributor

Hello,

Wanted to update those that are seeing this message at the top of their JSS web interface, but when we click "Update policies here" there are no polices to edit and dismiss the message. What we have seen is if we used Casper Remote to install a package, run a script, or a command that this creates a policy record in the database, but is hidden in the web interface. If the old path was ever referenced when we used Remote, this database entry is seen when 9.8x does it's one-off scan for the old binary. This is just a message, and does not affect how the JSS operates. We currently do not have a work around, or a time table for a maintenance release, but if you are seeing this behavior please contact your Technical Account Manager so that they can attach the case to this concern.

Thank you.442d69924f1e42fab1d6e49acc4ff533

5 REPLIES 5

were_wulff
Valued Contributor II

Hey all,

Just to expand a little on what @simon.heers posted: We have this filed as D-009675, which will be helpful for your Technical Account Manager to reference when you open a case.

The workaround to this particular issue requires that we run a command in MySQL, so it is something we'd want you to get in touch with your Technical Account Manager about as, done incorrectly, it could do anything from nothing at all to removing data that we don't want removed.

The exact steps necessary to clear the message can be found easily by your Technical Account Manager when referencing D-009675, and they will be able to assist you in clearing the un-clearable message in the screenshot of Simon's post.

Please note: The workaround for D-009675 assumes that we've already taken care of any lingering scripts or extension attributes that reference /usr/sbin/jamf and, that even after fixing the path, we're still seeing the error message show in the UI. If there are still scripts that may be referencing the old binary path, your Technical Account Manager can also assist in helping to get those fixed as well.

You can get in touch with your Technical Account Manager by either giving Support a call, sending an e-mail to support@jamfsoftware.com (it will route directly to your Technical Account Manager's case queue, and will allow for anyone watching their cases to assist in the event that your Technical Account Manager is out of the office or unavailable), or by using the My Support section of JAMF Software.

Thanks!
Amanda JAMF Software Support

Sonic84
Contributor III

Upgraded to JSS 9.81 over the weekend. We're seeing this too and will be contacting our TAM. Thank you!

chris_kemp
Contributor III

Here as well - dropped an email to get the command. Thanks for the posting!

gokoudes
New Contributor III
New Contributor III

Cheers for the post, as well! It's always a good day when you don't need to Google to see if this is a known issue.

charliwest
Contributor II

Did anyone ever get further with this issue? I have been seeing it for ages, went through the DB trying to find any mention of the jamf binary and remove them all, still get the same error