PPPC vs AppleScript / bash / Eclipse


hi folks -- I have an AppleScript, deployed as an app, which worked just fine until Mojave. The AppleScript includes calls to System Events and Eclipse.app, plus some shell commands. But since upgrading my lab Macs to 10.14, of course the user gets "[custom app] wants access to control “System Events“ " when the app is launched.

We have the PPPC JAMF / AppleEvents config installed already. Clearly that’s not enough. I downloaded the JAMF PPPC utility too, but it's a little opaque.

Does my AppleScript bundle need to be code-signed or something? If I re-compile the script with 10.14, will it just work? I know there’s documentation on these issues, but I’m in the weeds with the semester a week out, so would appreciate some guidance!

thanks everyone!



oh and also, the PPPC Utility refuses to add my custom app for some reason.

New Contributor

I also have Applescripts that are throwing the same dialog, but mine ARE signed with my Developer ID Application certificate. Doesn't seem to matter. These are very simple two-line scripts that dismount current remote volumes and mount a given server share. They've worked fine for years and now this. School starts on Monday and I don't have time to sit down in front of a few hundred Macs launching these scripts and clicking OK. Grrrr.