Printing issue with MacOS 10.12.1

Contributor II

We are experiencing printing issues with macOS 10.12. Everytime we attempt to print from macOS Sierra 10.12 machines, we get "Stopped - 'Filter' failed" and also receives problem report for "cgpdftops". We use Xerox printers so we tried the latest Xerox drivers as well as generic driver from Apple but it continues to fail. Is anyone else having this issue? I would like to narrow down if this is Apple issue or Xerox issue, I'm leaning towards Apple issue at this point since I'm using the generic driver and getting the same error.


Valued Contributor II

Try resetting the printer subsystem?

  1. Load the Printers preference pane.
  2. Right-click anywhere in the Printers list on the left side.
  3. Click 'Reset Printing System.'

Beware that this will delete all printers, reset all print settings, and restart the CUPS daemon. It won't remove any existing drivers. After you're done, try adding the printer again.

Honored Contributor II
Honored Contributor II

@tak10 With a little Google-Fu I found this article: Link

That was for El Cap but may help with your Sierra issue.

Are these machines that were upgraded to Sierra or fresh Sierra installs? If upgrades, you may need to uninstall all Xerox drivers and then install the driver that is specifically for Sierra.

If the suggestion to reset CUPS and install again does not work, I would take one system and install a fresh Sierra on it (erase and install) and do my testing on that. Or use a fresh virtual machine.