Problems with Netbooted Casper Imaging

jkuo
Contributor

Hi all,

So I've got NetSUS set up on Linux, and created a NetBoot Image using NetInstall Creator (https://jamfnation.jamfsoftware.com/viewProduct.html?id=13&view=info), using Casper Imaging 9.4

When I go to image a machine, it erases the disk, tries a block copy of our OS base image. It seems like the block copy doesn't do anything because it "completes" in a few seconds, and then it goes back to erasing the disk again, and then proceeds to install all the packages but fail on every one. It also fails to reboot, and there is nothing installed, no OS, nothing else.

Any ideas what I might be doing wrong here?

Actions from Casper Imaging log: Initializing Imaging Process... Mounting https://jds-01.ourdomain.com/CasperShareDAV/... Preparing disk for block copy... Performing Block Copy of 10_9_4_base.dmg... Cleaning up after block copy... Erasing Macintosh HD... Installing 10_9_4_base.dmg... Installing 1Password 3.8.22.pkg.zip... Installing Chrome 34 Bookmarks Plugins.dmg... Error: The file Chrome 34 Bookmarks Plugins.dmg could not be opened. Please verify the permissions. Installing DesktopBackgrounds.pkg... Installing Firefox 29 Bookmarks Plugins.dmg... Error: The file Firefox 29 Bookmarks Plugins.dmg could not be opened. Please verify the permissions. Installing Install iTunes 11.3.1.pkg.zip... Installing Fonts Full Suite.dmg... Error: The file Fonts Full Suite.dmg could not be opened. Please verify the permissions. Setting computer name to "test-02082"... Creating /private/etc/jamf.conf... Creating /usr/sbin/jamf... Creating jamfHelper...
Ensuring Apple's Setup Assistant does not appear... Creating First Run Enroll Script... Creating First Run Post Install Script... Adding line to Fix ByHost Files... Adding line to Create user flee... Adding line for installing InstallOffice14.3.8.pkg.zip... Adding line for installing Office 2011 14.4.3 Update.pkg.zip... Adding line for installing InstallSEP12.1.4.pkg.zip... Adding line to run aaFlushPolicyHistory.sh... Copying script aaFlushPolicyHistory.sh... Downloading aaFlushPolicyHistory.sh... Copying InstallOffice14.3.8.pkg.zip to FirstRun... Copying Office 2011 14.4.3 Update.pkg.zip to FirstRun... Copying InstallSEP12.1.4.pkg.zip to FirstRun...
Ensuring system files are hidden... Unmounting Distribution Point... Blessing System...

1 ACCEPTED SOLUTION

smith_kyle
New Contributor III

Are you using a JDS? If so, there's an issue with imaging via NetBoot and using a JDS for your distribution point. You'll need to use the script referenced here to create a fileshare distribution point on the same machine as your JDS:

https://jamfnation.jamfsoftware.com/article.html?id=369

Kyle

View solution in original post

3 REPLIES 3

emily
Valued Contributor III

This happens to me every once in a while and it is totally random each time. No solution yet, though my networking team recently switched the traffic to our JSS to an optical wave circuit so at least if it craps out I'm not wasting as much time… the worst is when the OS is the DMG with the permissions error.

tomt
Valued Contributor

@jkuo I've had this happen to me when the configuration profile has not been compiled in Casper Admin first. Maybe try compiling (or recompiling if you already did it once) to see if that helps?

smith_kyle
New Contributor III

Are you using a JDS? If so, there's an issue with imaging via NetBoot and using a JDS for your distribution point. You'll need to use the script referenced here to create a fileshare distribution point on the same machine as your JDS:

https://jamfnation.jamfsoftware.com/article.html?id=369

Kyle

View solution in original post