Profile Installation Failed

stoomey74
New Contributor

I have looked thru the boards but have not found a resolution for ; Profile Installation Failed - The server certificate for "myserver/enroll/SCEPProfile? invitation=xxxx" is invalid.

I made sure that my certificate is the local jss, the date and time are correct and I have tried different ways to put the server address in the jss http dialog box as suggested.
This is a clean install and I am starting over. The old server was setup bu someone else and was just wrong.

Any thoughts?
Thanks
Shaun

9 REPLIES 9

dustin_smiddie
New Contributor

I have the same problem. When trying to setup the JAMF for iOS 7, I had to reinstall the OS X from a clean and re-formatted RAID1. I am now running 10.8.5 with MySQL 5.5, and Java 7 with Casper 8.72 and my backups form the older 8.71. Everything looks like its there but none of my iPads are "checking in" after the upgrade and I can not add any iPad's into the server ether through Apple Config with an iOS 7 config profile, or Over The Air enrollment.

O.K. I just tried this from a tweet and it works so far. My MDM has picked up nine iPads in two min. and I was able to enroll my iPads into Casper. Here are the steps I used.

Resolution
If your web server certificate is self-signed, there are two ways to resolve the issue:

Replace the web server certificate in the JSS with the certificate from the JSS's built-in CA. Install a public certificate from a third-party CA.

If the root CA certificate is not being installed on the device during enrollment, ensure that this option is selected in the JSS.

To replace the web server certificate in the JSS with the certificate from the JSS's built-in CA:

Log in to the JSS. Click the Settings tab. Click the General Settings link. Click the Server Configuration tab. Click the Replace with certificate from the JSS's built-in CA link, and then click Save. Restart Tomcat. See "Starting and Stopping Tomcat" for instructions.

andy_cauble
New Contributor III

This probably seems like a simple solution, but also check that the date and time is correct on the iPad that you are trying to register. The student device I was working with was 1 hour off and this was causing the problem.

jonathanwilson
New Contributor II

This is a fairly old post, but I wanted to thank @andy.cauble for the common-sense reminder - I had this problem and it was because the date was way off. Like, 1970.

mmacpherson
New Contributor II

I know this is an old post, but I wanted to know if @stoomey74 ever found a solution? I too had to switch onto a new server. I had jss running on mac os and the hard drive was failing. I threw the jss onto a windows 2012 vm. I was able to successfully restore the backup. I am now however having issues getting my ipads enrolled. I am receiving the same error. The time on the server is correct and we did not have this problem in our network previously.

dimitrisamsonov
New Contributor

Check Time & Date and make sure it is set for you current time zone

ravijvp17
New Contributor

b5c36c1bb9b9495db3f8da447d708aca

When user Enroll the MacBook. We are facing this issue.Please help me.

ravijvp17
New Contributor
 

LMT
New Contributor II

Hi,
I'm getting a profile installation error from my A1822 iPad when trying to enrolling into our Jamf Pro account.
"The SCEP server returned an invalid response."
Anyone seen this error and have a fix for it? Please advise.

Loic
New Contributor II

245f0c2d028044dc9bc5a84d5fd8ad43
Hi @ravijvp17 I'm facing the same issue. Did you find out the solution, please ?
Best