QuickAdd Enrollment Failing

New Contributor II

I've been having issues with a computer checking in but never updating inventory. After looking at the machine more closely, it looked like the best recourse was to uninstall and reinstall.

I removed it from the JSS. I ran the removeFramework command and rebooted. I tried to use a QuickAdd enrollment freshly downloaded (it's a 10.12 machine). But it keeps failing with "The installation failed." error.

It looks like it at least manages to install the Jamf binary, so I've tried manually running commands to see if I can piece together the rest of the install.

But I'll get stuff like: The file /Library/Preferences/com.jamfsoftware.jamf.plist does not exist. Use the createConf verb to create it.

There is a problem with your syntax.
Error: The specified verb (jamf) is not recognized.

I've also tried manually removing all of the pieces before reinstall, but that doesn't seem to work either.

I've been reading through the forums to try to get a sense of what to try next, but I keep running into a brick wall. Any assistance you can provide would be much appreciated.