"Jamf" wants access to control "Microsoft Outlook

BookMac
Contributor

Hi folks,
we have a policy available in Self-Service, which executes a script that opens Microsoft Outlook and set some settings.

#!/bin/sh

#Get current User
currentuser=$(scutil <<< "show State:/Users/ConsoleUser" | awk '/Name :/ && ! /loginwindow/ { print $3 }')
echo $currentuser

#Runs Apple Script with current User
sudo -u $currentuser /usr/bin/osascript -e 'tell application "Microsoft Outlook" to set properties of exchange account 1 to {ldap server:"xxx.xxx.local", ldap use ssl:true, ldap port:"xxx"}'

When executed from Self-Service we are getting a pop-up asking for "Jamf wants to control access to Microsoft Outlook".

Bildschirmfoto 2022-07-13 um 11.52.11.png

We've created a mobileconfig with PPPC but still get the pop-up.

Screenshot 2022-07-13 at 11.51.22.png

Screenshot 2022-07-13 at 11.51.24.png

Screenshot 2022-07-13 at 11.51.29.png

Screenshot 2022-07-13 at 11.51.32.png

Screenshot 2022-07-13 at 11.51.34.png

Screenshot 2022-07-13 at 11.51.38.png

Can someone give us a hint how we can solve this?

thx and regards!

 

0 REPLIES 0