"The iTunes Store ID of the application could not be validated." on one device with 2 apps in static group

New Contributor III

I currently have 30 iPads in a static group that were all supervised using Apple Configurator(were still jump through hoops for DEP). 29 of the 30 iPads all have configuration profiles with restrictions that are applied and working on all 30 devices.

We have VPP setup to push Onenote, Outlook, and Self Service mobile to all devices in the static group, but one iPad will not except apps, even though it is supervised.

It prompts for iTunes credential, I hit cancel and it installs OneNote and nothing else. I then get the following errors for Self Service and Outlook:

The iTunes Store ID of the application could not be validated.

This error only appears on this single device. I have wiped it several times and re-enrolled it using Apple Configurator and manually through Safari, but I always get the same result: OneNote without Outlook or Self Service and a prompt to sign in with Apple ID.


I've also tried removing the entry from the JSS and re-enrolling but the same thing happens every time.

I even tried creating a new app policy for the single device, just to be sure I could do it.

I compared all app settings, between One Note and the others and they are identical.


New Contributor

I'm getting the same error on 30+ iPads that are all enrolled in DEP.

New Contributor II

Getting this error on first two iPads of my fall deployment. :-/ Call to Jamf for help.

New Contributor III

Jamf are having issues with VPP i got a ticket logged which they are investigating at the moment the issue they said to me the following "a product issue from our side. PI-002501"

New Contributor

Hey, I know this is a little old now but I'm seeing the same failed commands for a certain set of iPads in the JSS while all others are deploying ok. Does anyone know a workaround or the progress on PI-002501?

Currently we are running JSS 9.93. Cheers!

New Contributor

Im on 9.96 and showing the same error. any fixes?

New Contributor

My iPads are facing the same problem. Any work around? We're running on 9.96.. Thanks.

Valued Contributor

We had this with some older devices that had been setup with VPP before. We logged a call with Jamf Support and we ended up running some MySQL commands to renew all our VPP licenses. I think the issue was due to some duplicate licenses trying to be assigned to the same device:

Issue Summary

The iTunes Store ID of the application "number" could not be validated.

Root Cause
license duplicates

I won't paste the solution summary as it contains the MySQL commands that need to be ran to clear the VPP codes. I'd suggest opening a support call with JAMF and have them guide you through it.