Random pre-stage imaging failures

Valued Contributor

I have been erasing and re installing several Labs of Macs and I have run into a issue with it.

The normal process would be to erase the Mac and reinstall Monterey. On first boot you get a few windows pop up for setting up services, then you get the Remote management one, on which I hit continue. The Mac will then find our Jamf server and connect ot it and download the configurations and enrol its self with the server. Then it will continue with its enrollment policies and so on.

However, and this is really random, sometimes it appears to get to the end of the Remote Management section and then simply shuts down. The Mac appears in JAMF with a name starting with DEP-. But as far as I can tell it is not fully enrolled because I cant send policies, or use Remote to SSH in to it. The Jamf Admin account is set up on it as per the Pre-Stage set up.

The only "Fix" I have found is to erase it and start again. Sometimes this will work and the Mac will complete, sometimes I have to repeat this again. To date I have had to repeat up to 4 times for a few.
Because we have been having an issue here with Macs dropping their server connection, I have been erasing labs multiple times, and it isnt the same Macs that fail each time. It can be up to 50% failure rate in a lab, or none.

I am deleting the computers from Jamf as I set them to erase.
I have a totally new Pre-Stage setup, and it happens to that as well as the old one.
It will happen if I am working on one Mac or many Macs.

It is a feature that is getting old fast, and I have our main Summer round of re-imaging Macs to get into.

Anyone got any suggestions of what to look for to try to eliminate this? 


New Contributor III


Our DEP started freaking out about a month ago when I made a new Prestage and assigned about 100 computers to it.  I was having similar results as you with the computers enrolling as DEP-, with no functionality although the Jamf MDM Profiles were installed.  It was almost exactly as you describe.  Jamfs solution was to Unassign ((NOT RELEASE!)) those computers en mass from Apple Schools, wait 15 minutes, reassign to them to our MDM Server en mass from Apple Schools, wait 15 minutes, and assign the computers back into the Prestage.  It seemed to work.  A few days later, Jamf released Jamf Pro 10.38.1 which specifically addressed

  • [PI110078] Automated Device Enrollment no longer fails if there is duplicate data in the Jamf Pro database.

I did read some information about duplicate data causing DEP Enrollment problems too.   However, since the Apple Schools DEP server reassignment suggestion from Jamf Support, and 10.38.1 I have not had any problems.  I hope that helps!

Valued Contributor

I tried this and still had failures.
On Slack there was a suggestion to not make the management account hidden in the prestage setup and that had fixed it for one of them there.
Testing that today, and so far had no failures, but only done 5 so far.

I spoke too soon, the very next one I tried failed.