Reaper in a multi-user (classroom) environment and some issues

New Contributor

I came up empty on Jamf Nation and realize this isn't specifically a Jamf-related thing per se, but maybe you guys would have some ideas. I'm in IT at a university where we just upgraded some of our audio software over the winter break, including Reaper.

I initially did an update from 6.66 (hail Satan) to 6.83 using a package created in Composer and then scoping it as a policy, pretty straightforward. And that was fine. The problem is that our license isn't valid for version 7, and I don't have much of a paper trail as to how Reaper was originally deployed and what we actually paid for, etc. Long story...the guy before me left some notes but it's taken some reverse-engineering to get things going again.

So I ended up just buying 13 of the $60 discounted licenses for one of our classrooms rather than trying to retrace our steps from the last purchase. Went around logged in under the [local] admin account and licensed a few computers, so far so good...then logged into my own network account instead (which is how the students log in) and opened Reaper, and it prompted for the license key all over again.

When I emailed their support team about it, I'd already tried moving plus the license key file to the main Library folder rather than ~Library. This did not fix the issue, and so far it's been their only suggestion.

So is it possible one of our Jamf policies is causing this somehow (I don't have full admin access so I can't edit policies)? And/or, is this something I can fix via Jamf by re-packaging Reaper (sigh haha) and then adding a post-install or post-flight script to point it to that main Library folder? I kinda remember running into something similar with Ableton, only their suggested fix actually worked and involved modifying a plist file IIRC.

Any ideas? Thanks!


New Contributor III

Hi bart55,

I also work for IT at a University and we deploy Reaper to one of our labs.

We deploy reaper as a pkg and then deploy the license file directly to /Library/Application\ Support/ REAPER/reaper-license.rk. We do not sign in locally to license the software, though that may be how we originally generated the license file. We also do not deploy a Plist or settings after the license file to "license" it. Reaper has been very nice about seeing the file in /library and automatically picking up the license. 

One thought is that if you generated the license file under a specific account does the license file reflect that account? i.e. can only the user "Admin" read the file? We deploy it with owner:root, group:wheel and 644 as the file permissions. 

If permissions and owner seems good there may be a plist or setting file somewhere that gets generated at first launch that is looking in the old ~/Library location. 

You could try a fresh install of reaper, copying the license file (with verified permissions) into place, then launching it and see if it licenses for all users then.

New Contributor II

how are you deploying the licence using a snapshot pkg?


New Contributor III

I generate the license file manually which creates the license file at "~/Library/Application Support/ REAPER". I just checked and it looks like I'm capturing the whole REAPER folder, I don't know if that's necessary but it is what I'm doing. I move that folder to the same location at "/Library/Application Support/REAPER" then drag and drop that folder into Composer. I leave the permissions alone but change the owner:group to root:wheel.

New Contributor II

Hi, Yeah thanks that did the trick. i made one last year, but couldnt remember how i made it.  And it stopped working when we went from jamfcloud to on prem.  probably unrelated, but i needed to make a new one for V&V purposes before we go live.

Valued Contributor

I dont deploy Reaper, but with troublesome Apps like this, I usually work along these lines...

1. Check permissions and location of the files. Make sure all of your users can access them. Anything it makes in the User account Library for licenses, I would duplicate into the main Library in the same location.

2. do step 1 and then, check your network account for copies of the license and remove them and try again, it may well pick up the new license this time around.

3. Try installing the app and initial license whilst logged in to the GUI as root. I have several apps where this is the only way to install them and get the license to work.

4. Test if a copy of the license file dropped into a users account library folder works. If it does then it will be possible to create a LaunchAgent to run a script to put the license file into each users Library and make it work that way. Remember LaunchAgents run as the User, so all files need to be located where the User account can copy them for a script to work.

1 and 2 are how I fixed Ableton, before I had their License server solution. 3 is how I install Silverfast scanner software, even though their support said multi user was not possible. And 4 is where I ended up for a couple of other Apps.

Generally Apps will look in the Users Library for a license, and if nothing is found there they will progress to the main Library folder. If that fails they will then ask you to license the software. 

Contributor II

I manage all our music tech apps by login scripts. Things like Logic, Pro Tools, Wavelab, Sibelius can really benifit from the local admin having already run the 'scan for audio units' step.

Some plugins/Apps will behave nicely with license files in /Library, other require license files in ~/Library

In the instance of ~/Library, I'll script to copy from local admin to the current users ~/Library.
That way if licensing gets updated mid semester, I can relicense machines, and flush all the login scripts for that applications via the policies logs.

With Reaper, even though we don't license the app, I still use a login script to copy files from local admin. This is because they use the Ambisonic Toolkit ATK plugins, and the installer they provide is an MPKG that runs 3 installer pkgs in user context (putting files in ~/Library). In order for other users to see them, a login copy script is used.

When handling licensed complex apps for the first time, I save myself the headache and do a snapshot install from Composer. Once I remove all the bumph that I know shouldn't be included, I get a good picture of what's going on during installation. I keep a screenshot in my OneDrive for the next time I have to package it. It also helps in determining where your license files live and where Application data is being stored.