reoccurring Device Signature Error

Contributor II

I have a machine that keeps getting Device Signature Error if I try to run sudo Jamf policy or sudo Jamf recon.

I can temporarily fix this error for a few days if I removeFramework and re-enroll the machine.  The the error will come back

Fri Jun 17 10:14:04 IN-XXX-180122 jamf[75414]: Error Domain=com.jamf.jamfsecurity.error Code=-25293 "unlockWithPassword:error: : The user name or passphrase you entered is not correct." UserInfo={NSLocalizedDescription=unlockWithPassword:error: : The user name or passphrase you entered is not correct.}

Fri Jun 17 10:14:04 IN-XXXX-180122 jamf[75414]: 

There was an error.

     Device Signature Error - A valid device signature is required to perform the action.

The time is correct on the machine.  Anyone have any ideas on this?


New Contributor III

I'm having the same problem on a few computers that I enroll with a QuickAdd package, not through DEP.  The Device Signature only stays valid for about 15 minutes.

I'm seeing the same thing with QuickAdd enrolled devices. Have you found a solution?

New Contributor II

Are you also deleting the computer record in your JSS before removing the framework and re-enrolling?

No, I will give that a try.  Thank you.

Tried removing framework, deleting computer record in JSS, and re-enrolling.  Worked for a while but back to device signature error.