Screen Recording Permission but App Not in List?

New Contributor III

Never run into this before, but we are seeing with "Class for Zoom" app (bundle ID com.classedu.classforzoom) in Catalina and Big Sur. Local admin user running Class just fine, can allow camera and mic when prompted by app, but when attempting to screen share it requires the screen recording permission. App prompts to enable, has a button to take user there in Security & Privacy, but there is no entry for them to check once there. There is no ability to manually add an app to this section, and PPPC can only push a profile that allows standard users to approve this setting.

We have a case open with developer, but not 100% sure this is not a problem we are creating. I have flushed TCC for bundle ID, deleted and reinstalled from a fresh dmg download, nothing else has ever been a problem with this setting.




Contributor II

Hi @cboatwright,

To further narrow down where the issue is, I would try installing the app on a fresh install of Catalina/Big Sur on a device that is not managed by Jamf and see if you can enable screen recording when prompted.

Has this app previously allowed you to permit screen recording?

New Contributor III

I went back to a MacBook, erased and installed a vanilla version of Catalina without any interaction with Jamf. Proceeded to install latest version of Class for Zoom, launched from Canvas integration, share screen in app = blank pane in Security & Privacy tab for screen recording. I am confident this is not an unintended restriction being applied from Jamf policies.

New Contributor II

Curious if there has been any update to this, we are having the same issue. Seems to be only on machines that have had the OS updated. For us it is the main Zoom client. Tried updating and reinstalling the app, tried clearing tcc. Only fix has been to wipe and install OS. I'd like to avoid that though on the number machines needing OS updates.