Self Service apps won't install onto iPad 3

New Contributor

When I first got Self Service through school on my iPad all apps downloaded straight away except for two but ever since none of the applications are installing. When I click install it stays stuck on 'Your app install should begin shortly.' No popup appears no matter how long I wait. All help is appreciated.


New Contributor II

I'm in the same boat as you! It has worked for a majority of iPads but I have 4 or 5 persistent that will not allow me to install just sits on your app will install shortly.

New Contributor

I saw this today on my managed iPad 3 and got the same error as the OP (it has worked properly in the past)
I re-enrolled the device from the iPad itself and its working now. question is, how many other devices out in my environment are having the same issue without me knowing...

New Contributor

I'm in the same situation....just re-enrolling the device worked? However, we have over 200 that are not downloading the two or three apps. Once you re-enrolled the device, did you have to reinstall all the apps that were already loaded?

New Contributor

Having the same issue on hundreds of iPads in a new deployment. Re-enrolling manually on each iPad not a viable solution. Anyone else with a suggestion?

New Contributor

Any updates on this?

My wife's classroom iPad 3s have this problem. Most download successfully. Some spin and never download.

The iPads are running iOS 8.1 and Self Service 9.4.