Self Service has Encountered a Problem

jennmurphy
New Contributor II

Hey jamfNATION,

We have a user that cannot download software from Self Service without it crashing (error message attached) - we have to force quit Self Service and reboot the machine multiple times, but Self Service continues to fail when attempting to download. It is a recently imaged machine, we are on jss 9.97, and the user is running macOS 10.12.5. Has anybody who encountered this found a solution?

Thanks!

4 REPLIES 4

mm2270
Legendary Contributor II

Couple of things to try.

Re-enroll the Mac into Jamf Pro, even if you think it already is. This can be done with a full QuickAdd pkg built from Recon.app or by going to the JSS enroll page if that's enabled, signing in and downloading/installing the QuickAdd.pkg from there.

Second, delete Self Service.app. Drag it to the Trash and empty it. Now go into Terminal and run the following commands.

sudo jamf recon
sudo jamf policy

Self Service should get re-installed on the second step, assuming you've enabled the option to automatically install Self Service on enrolled Macs in your JSS.

After these steps, try using Self Service again.

Chriskmpruitt
Contributor

Try deleting the Self Service app and run the following command from Terminal

sudo jamf policy

this will install the latest Self Service from your JSS.

drheiner
New Contributor III

We have this problem as well and have an opened support case on it. Under ~/Library/Logs/Jamf you can put Self-Service in a debug mode and pull and post the logs (defaults write ~/Library/Preferences/com.jamfsoftware.selfservice debug_mode -boolean YES). I bet it is error code 20.

What we have been told so far is there is a defect in self-service which seems to kill one of the jamf agents in which allows the workstation to talk to the server regarding Self-Service (Not the binarys)
To quickly resolve the issues run the "Sudo jamf manage" under the end-users account. This will restart the service. Make sure you have closed self-service before you run this command.

HimanshuPawar
New Contributor

I have had the similar issue.
Tried the below steps and issue has been resolved.
1. Uninstall the Self-service by simply moving it to trash from Applications.
2. run sudo jamf enroll -prompt to repair the JSS Client.
3 Clear the self-service cache from ~/Library/Caches
4. Reboot the Mac.

Launch self service after rebooting the mac