Self Service v10.30.3 macOS not connecting


I upgraded to 10.30.3 yesterday and noticed now that my macOS Self Service is not connecting, iOS Self Service is still operational.  There is no crash like I've read others experiencing.  I am working with support on this, just curious if anyone else has ran into this and possibly found a fix?

Screen Shot 2021-07-15 at 10.00.03 AM.png




Honored Contributor

What happens if you type this on the Mac:

jamf checkJSSConnection

Yep one of the first command I ran, "The JSS is Available"  Push Cert has a valid date, and commands from the JSS to a macOS device are also working.

Honored Contributor

So, what if you delete Self and then run a recon - it should give you a new SS app.  See if that helps, and possibly, look to Keaychain to remove the SS keys before installing SS again...



I've tried that as well.  No luck.

Honored Contributor

Have you tried unenrolling and re-enrolling?

Double-checked that the MDM profile is still approved?

I hadn't tried a re-enroll until your suggestion.  Thankfully that didn't work.  I couldn't imagine having to re-enroll 5000 computers just to get Self Service to work. 

MDM Profile looks good.

Honored Contributor

Take a look at this thread - so many possibilities that I think maybe something in there might help.

Also, if you have other items involved like Intune, Jamf Connect, etc. there may be more complex issues at hand...

Check this link below:

Self Service Issues 

Contributor II

I was running into this issue this morning. I was attempting to install some VPP apps from Self Service and it was failing immediately with the error reported by OP "Couldn't connect to the Jamf Pro Server. Try Connecting Again". I checked to make sure I could retrieve policies and ran recon all fine, so I uninstalled and reinstalled Self Service and seemed to clear up the problem. If the issue comes back I'll update.

New Contributor

I am also having this issue, started when I updated as well. I have tried all of the solutions suggested below. Deleted the app. Reenrolled. Removed the keychain items and no solution.


I might have a new cause and fix for you.  Support found my problem.  If you currently have any macOS Configuration Profiles that have "Make Available in Self-Service" it is causing Self Service to have this problem.

Fix and I quote Austin from my support ticket  "You can either set this to deploy automatically or disable/delete it.  If this fixes Self Service, we are running into PI-009440, a known issue with this version of Jamf Pro that is caused by adding a malformed Configuration Profile to Self Service."

I hope this helps!



I had two com.jamfsoftware.SelfService.privatekey entries in the login Keychain.

Deleting both the private keys, public key and Self Service, then waiting for Self Service to get re-installed sorted it for me.