Self Service & VPP Managed Deployments of One Drive - Self Service crashing

New Contributor III

I'm trying to deploy Microsoft OneDrive through a Managed Distribution. I've set up the purchase through our VPP enrollment and I'm able to create the Mac App Store App as a deployment through Self Service, but when we click on the app in self service, the application with the error "Self Service has encountered a problem. Quit and reopen Self Service to try again."

9/15/16 11:48:26.892 AM Self Service[3038]: [ERROR] -[SSDeployableObject handleTimeoutError:] (line:364) --> Quit and re-open Self Service to try again.: (null)
9/15/16 11:48:26.893 AM Self Service[3038]: [ERROR] -[InstallerQueueProcessBinder finishProcess] (line:191) --> Mac App OneDrive failed with: Error Domain=JAMFSoftware/SelfService Code=20 "Quit and re-open Self Service to try again." UserInfo={NSLocalizedDescription=Quit and re-open Self Service to try again.}

I've also tried to Install Automatically/Prompt Users to Install, but it doesn't seem to install on any of the scoped machines. My targets are Specific Computers and all users in a specific Smart computer group.

Any ideas welcome!



Valued Contributor III

I take a somewhat unorthodox approach to OneDrive. It works, but getting it deploeyed to my liking is tricky.

For starters, I use a configuration profile to get the settings tweaked to my liking. I scope the profile to a "has OneDrive" smart group.

Finally, and this is key for us as I don't trust new OneDrive updates straight out of the gate...I don't deploy it through the Mac App Store. I used Rich Trouton's method of getting an app out of the App Store. Documented here:

With this I control the version of OneDrive we want to support and publish new builds to Self Service when we are good and ready after testing. I'm willing to share my .mobileconfig file if anyone is interested.

Also note that this "getting the package out of the App Store" method may not work if MS later implements receipt checking.

New Contributor III

Yep, no longer working with Sierra. Debugging menu is no longer available. Well, it worked in the short run.


The OneDrive client is now available as a stand-alone package as well, though it has its own self-updating mechanism, which kind of blows you up for version control...

Contributor III

I'm seeing this same behavior currently deploying Sierra through VPP/Self Service. The installer downloads fine but Self Service crashes.