Sender email address in SMTP settings as well as the Enrollment Invitations

New Contributor III

Hi All,

I'm not sure if anyone else has seen this.

We recently moved over to JAMF cloud and upgraded to the latest rev of Casper.

We had to set up a special account for our SMTP emails from the site through O365 vs. our internal SMTP service account. It's working great except for one little problem. Instead of using the SMTP Email address that the JSS says it's going to send mail out from, it's using the Username of the account, which is so wonderfully cryptic. I have no problems with that for the server mails to my team but this is the same address it's sending from for the enrollment emails. The username is so cryptic that I can see users seeing it as SPAM.

I also tried changing the FROM address in the enrollment emails but it's not using that entry. Is this a bug or am I missing something?



Contributor III

We're seeing this, too. Seems to only use the address that's authenticating. I'll be watching this thread!

New Contributor III

So I opened up a ticket about this, and they closed the ticket after sending me instructions for enrollment invitations where the instructions says "Follow the onscreen instructions on filling out the enrollment invitation". So after submitting another ticket, they finally did get to the core of the issue. Simply typing the address in the invitation isn't enough. You have to add the "sender address" email to your SMTP mail provider "alias" settings. We use gsuite and it entailed me adding the alternate email to my "jamf email" account's list of emails it can send on behalf. Once this was done, just type the same email address into the "sender address" portion of the invitation and presto.

Valued Contributor II

@Tjernigan how did you do this with gsuite? did you have to get something enabled first by your gsuite administrator?

i can't send out an enrollment invitation. I keep getting failed to send invitation.

I believe this is the issue i need to get setup. We moved to JAMF cloud and ever since I do not get any of the notifications i previously was getting before moving to jamf cloud.

New Contributor III

@ tcandela failed to send invitation is a whole different issue. If it were an issue with getting an internal email to appear to send the invitation, the invitation would still go out. It would just be from the email you setup for the jamf server. in gsuite, you have to actually go into the mail account you want jamf to send mail as. You then have to go into the mail settings and enable "Allow to send mail on behalf" and your jamf account email should be added.

New Contributor

@Tjernigan do we need to setup up smtp server on gsuit as well. As in to configure jamf smtp in send mail as