Setting Google Chrome as default browser on iPad.

New Contributor

Hello all. I am using JAMF Pro to manage a group of iPads and need to turn the default web browser from Safari to Google Chrome. We are using the iPads to canvass voters, and we are using an online form as opposed to an app. I have set it so the websites have been whitelisted and able to be loaded which works. After that I created home screen icons using webclips and set them to the home screen. 

Right now, from what I can tell, clicking the icons on the home screen first attempts to run them via Safari, then they transfer to chrome. I have tried just turning off Safari using the JAMF configuration profile, but instead of opening the webapps are inactive.  I went into the setting of Google Chrome and switched it so it says it's the primary browser, and checked Safari which also said the same. Is there a way to set Google Chrome as the default without it attempting to open webclips via Safari first? If not, is there a better way to get these links to open in Google Chrome without needing Safari? Thanks in advance! 



you can try setting your webclips to open the chrome uri. chrome://

New Contributor II

That doesn't work. I'm having the same issue. Jamf isn't very good if you can't even set a default browser, this is crazy.