Single App Mode + AirSecureTest App

New Contributor III

Our district starts testing pretty soon and we are trying to set up Autonomous Single App Mode. The app we are using for testing is AirSecureTest. We set up a test device and pushed a configuration profile to it locking the device into the app, but we're encountering an issue. Specifically, we want the app to be able to close once the student has finished the test and thus turn off the configuration profile.

We went through and took a practice test and once we were done we were unable to exit the app without turning off the configuration profile. From what I can tell, there's no way for the app to communicate with our Casper server saying that the user has finished the test and to thus unlock the device. Is there a step we're missing? Or are we going about this in the wrong way?


Valued Contributor

You could use Casper Focus to put all the testing iPads into a class and give it a time-frame, or have the proctor use Focus to let them out when they're done, but to my knowledge once the JSS puts you in Single App mode you're stuck there without intervention.

Otherwise you could enable guided access and have the proctor taking them in and out of single app mode manually.

I can't think of a way that the iPad could communicate back to JSS that the test is over.

Contributor III

Does the app support Autonomous Single App Mode? The way I understand ASAM works is that the app itself locks them in and releases them. You aren't locking them in the app with Casper.

You do need to send a profile from Casper allowing ASAM. It's under Restrictions > Applications tab. You put in the bundle id of the AirSecureTest.

Release Candidate Programs Tester

Looking at the app, it says it should support Autonomous single app mode assuming you are using 3.0 which just came out 4 days ago.

You will want to make sure you are using the autonomous single app mode like @Nick_Gooch mentioned above. Past that, it would be an AIR support call.

New Contributor III

@Nick_Gooch That seems to be the setting we are looking for. However, I created a profile and pushed it out to one of our devices and I am getting an error saying "The test environment is not secure. If you're using an iPad make sure it is in Guided Access or ASAM." Is there a setting within the app maybe? Or another setting in JAMF I'm missing?

New Contributor

Hi, I am running this in our Casper 9.63 with Casper Focus 9.63 on our teacher iPads and our test so far have been very eye opening. I ran into a problem when one of my teachers did not remove focus on a group of iPads and they have lost W-Fi connectivity. They are locked up and just say 'No Internet Connection, please check your network settings and try again.' Does anyone know how to get out of Casper Focus when you are locked into AirSecureTest APP and the iPad will not see your Wi-Fi SSID??? I can not even re-image it with my Casper server as my on site DEP MDM device. It just goes right back into the APP and is bricked.

When I run the tests to see if I can run 60 -80 iPads at one time they work. We are building up to the needed 850 iPads at one time at one school. We found if something else happens in the background then the APP locks up and the iPad is a brick. Like if the "Auto-Lock" were to dim the screen or shut it off during the test the APP locks up. Or if the iPad were to switch from one SSID to a second, or the on screen keyboard try to come up while you have a 30 Pin or Thunderbolt Keyboard plugged into the iPad, the APP locks up and you have to Update Focus, remove the APP, then Refocus the APP back again. If you are locked into Single App mode and loose Wi-Fi then you iPad is bricked. FSA has some bugs and I am unsure how to fix our iPads when they get bricked up like this.

Anyone got any answers? Or thoughts?

Valued Contributor

You'll need to use Apple Configurator to reset the iPad, I believe you can leave it unsupervised and then let your own DEP takeover when the iPad starts up for the first time.

New Contributor

I pushed out the profile enabling the ASAM with AirSecure test bundle ID. Tested and went thru a couple of questions and it worked. However the team mentioned last year during this test the wifi kept going out on the iPads. Guided Access manually set on each iPad allows a key combination to get out of the locked test. Does the ASAM allow something like this? Has anyone experienced this? Any workaround? Just in case we need to exit the test or app and it is not responding to Air Secure's Save or Pause feature, will i need to take that iPad out of the scope? I am not using casper focus. Will I need to? thanks guys.

Valued Contributor II

@paliteach You have probably figured this out already but with ASAM there is no JSS communication needed so if something locks up or WiFi drops the app'll figure it out and break out of Single App Mode. If not just restart the iPad.

Using Focus or sending profiles to put an app into Single App Mode is risky as you need that communication with the JSS in order to get it out...