SMB open sessions

New Contributor

Hello all,

We discovered nasty behavior connecting from Mac 10.8 10.9 and 10.10 clients to Windows Server 2008 R2 and up over SMB.

Finally filed a bug report with Apple but we got back the completely useless answer: Duplicate of 13724789 (Open). Without any further info or feedback. Even the Apple SE for our region left us hanging. Until our JAMF SE suggested to post this issue to jamfnation...

Since Apple is pushing the whole "switch to SMB" and integration in classic MS environments, we consider this to be a maaaaajor issue, as it hits a lot of our customers.

This is our bug report to Apple, any help or insight is greatly appreciated.

Summary: When connecting to a Windows Server with a OSX 10.10.2 client for filesharing over smb, several of our customers encounter this problem. After connecting to a Windows Server, we navigate to a folder X and are able to change the name of that folder. After that we navigate into the folder and back out. After that we are not able to change the name of the folder: OSX asks for local admin rights. When we provide local system credentials we get the message that we do not have the right to change this folder. We encounter this problem with different client OSX systems, and with different Windows Server systems (2008 R2 and 2012 R2) in different environments. Steps to Reproduce: 1. Connect to a Windows server over smb or cifs from a OSX client 2. Navigate to a random folder and change the name to ensure you have the correct rights. 3. Navigate into the folder to another folder. 4. Navigate back to the original folder 5. Try to change the name of that folder. 6. Disconnect from the server, reconnect and retry to rename that particular folder --> now it works again. Expected Results: The ability to change that folder's name and the ability for other users to change that name. Actual Results: Local OSX system asks for local admin authentication. Once authentication has been provided error message occurs about not enough rights for that folder. Version: 10.10.2 and all previous versions, as well as 10.9 and 10.8 Notes: We already tried disabling QuickLook, Spotlight and DS store files for netwok shares, all without success. Tried SMB or CIFS. On the Windows Server, you can see that OSX clients keep folders open in the smb session, even after navigating out of that folder. Windows Clients do not show this behavior. Configuration: OSX Client 10.10.2 -- 10.8.0 (all versions tested) MS Windows Server (tested 2008; 2008 R2; 2012 R2 in different environments) Macs not AD bound (no Kerberos, etc.)

New Contributor II

Something similar, but maybe not related, that we've seen since moving to Mac OS 10.9 - on our NetApp file storage we "often" get errors when trying to move folders with files. After much testing, we discovered that the "icon preview" function on the Mac Finder is keeping the files look as if they are still open to the server. Logging off would always clear it up. But our permanent solution was to disable icon previews in all Finder window views, as well as disable icon preview in Photoshop (and any other apps that perform that function).
Have not fully tested Mac OS 10.10.3 yet on this issue.

New Contributor II

Another issue we have with the NetApp (via smb) storage is real odd behavior that sometimes causes hangups, or prevents users from dismounting a server volume is having any kind of server volume, folder, or file "alias" in the Finder window's sidebar.

New Contributor

Hi ronb,

Were you able to automate disabling icon previews with a casper policy or did you have to make these changes manually? If you used a policy or script, would you be willing to share?

Best regards,

New Contributor II

Hi Neil,

I was never able to get that. The work around I had was to just capture a few user preference files and put them in the user template - something I always try to avoid. And since either Yosemite or El Capitan broke that preference file as far as icon preview, this is a good reason why.
Glad you asked though, cause I hadn't realized the icon previews were back after these last two OS upgrades until you got me digging into it.
We now have an applescript "app" that we run on each user initially. I'll investigate to see if I can find an AppleScript command to disable the icon preview settings.

Contributor II


We posted about this in our blog:

Mac Bug Connecting To Non-Apple SMB Shares

We filed a bug with Microsoft & Apple enterprise support and it was found to be a Apple bug and is rumored to be fixed in macOS High Sierra. I would recommend testing the macOS High Sierra beta/GM or wait until the official release on Sept 25th and test again.