Software Update - Authentication is Disabled

Valued Contributor

Just wondering if anyone has seen this.

Screen Shot 2023-11-28 at 1.34.25 pm.png

 The machine is Ventura (Mac OS 13.6) and trying to upgrade to Mac OS 14.1

Machine is bound to an AD domain and the user has a secure token and is an administrator on the machine.  The user is logged on with a domain account i.e. a mobile account.  The machine is an M1

I tried forcing the update/upgrade via Jamf using the MDM framework from the server as they are overseas but it got to the end of preparing and prompted them again


New Contributor

Below post can help you. Since authentication is not failed but disabled which might be due to issue with secure token.

Esteemed Contributor II

@dlondon If send the update command with a user deferral option it'll always prompt for credentials. Use the option to download and install immediately to perform the update without user prompting. You might also want to have the user restart that Mac if it's been up more than 7 days as that seems to be the threshold (at least in my environment) when macOS Ventura starts to have issues with the MDM pushed update command.

Valued Contributor

Thanks @sdagley and @user-rLcbGKzEGV the user is overseas and has been out of contact since I asked them to check a few things for me.

I'm going down the secure token rabbit hole to see if setting it off and then back on will have any effect. 

Steve - I did try the MDM command via Jamf and install immediately without prompting but nothing happened.  I will check on the restart before doing the update comment to see if that helps.

New Contributor


I have tried Re-enabling the Secure Token.

Still the error is same

Kindly help on the same

Thank you