Sophos AV install question



I am in the process of building packages to use with our brand spanking new Casper Suite. I have run into a couple of problems but I'm going to post them one at a time and try and get some feedback on them individually.
We use Sophos AV and I have tried using Composer 7 to make both a dmg and a pkg to use with Casper, but have not been able to get a working copy of Sophos out of it. There are two problems, firstly after being installed (either via policy or Casper Remote) the Sophos Updater pops up with an error saying is can't be started (this sometimes takes a couple of minutes to appear after the install). Secondly the Sophos menu item does not appear (this is a check box in the Sophos Preference Pane).
I then tried using the vanilla mpkg that Sophos arrives as, but when I try and install that via Casper Remote it fails, and I get this message in the jamf logs:

Fri Feb 27 12:37:57 A7388 jamf[1544]: Installing Sophos Anti- Virus.mpkg...
Fri Feb 27 12:37:58 A7388 jamf[1544]: Installation failed. The installer reported: installer: Error the package path specified was invalid: '/Library/Application Support/JAMF/Downloads/Sophos Anti- Virus.mpkg'.

Finally I went ahead and installed it using Apple ARD, and it worked fine.

so...any suggestions on how to get Casper to install Sophos AV successfully?



Paul Benham
Desktop Operations Specialist
Bates College
110 Russell Street
Lewiston, ME 04240
PH: 207-786-6382
pbenham at


Contributor III

The other guys nailed this already with the permissions thing. The other thing is I don't think their installer is agreeable with changing the name of the mpkg at all, but you haven't. Their uninstall pkg inside the installed application is handy as well. I also never had it working to install Sophos at the time of imaging using Casper Imaging so it deploys with a policy once the system is up in running normally after imaging.

Craig E



With regards to the 'vanilla' mpkg...

We had the same problem at our district. We found that once we had the mpkg
loaded in our Casper share, we had to launch the JSS Setup Utility, select
File sharing and Fix permissions. Once this was done, the package worked.
We then created a follow-up package to create our network settings.

Hope this helps,

-- Mark Sampers
Technology Support Cluster Specialist
Independent School District 196


I was just gonna suggest permissions , I always check permissions in server admin for the Casper share everytime I upload a package. Also propergate the permissions into the mpkg as that might make it fail. If the sub packages have incorrect permissions