Suppress Outlook Autodiscover

Gonzalo
New Contributor III

Hey,
I'm trying to find some way to suppress the autodiscover redirect popup. (YES I have search the forum here and tried the suggestions)

We have an Exchange 2016 on prem hybrid solution.Autodiscover URL runs a split DNS. One points to an internal load balancer and the other points to an external reverse proxy load balancer, that points to the internal exchange servers.

Our clients runs the latest version of Outlook 16.67 (O365 licensing), both on Monterey & Ventura.I have a configuration profile through Jamf with the TrustO365AutodiscoverRedirect key set to true with no luck. Have also tried with SuppressO365AutodiscoverOverride,  same result as before. The popup appears again for those users who have nog pressed "always use my response for this server..."

Screenshot 2022-11-18 at 06.48.36.png

3 REPLIES 3

piotrr
Contributor

EDIT: That's a bummer. I have scoped the same setting and I thought it worked. :/ 

In the configuration you have scoped, have you made any other settings that you can verify that they apply? That way, you can determine if the configuration profile works at all, or if it's blocked somehow. 

Gonzalo
New Contributor III

@piotrr Thanks for reaching out. Our profile looks like this.
The first two settings work, the other two autodiscover doesn't seems to apply.
Screenshot 2022-11-24 at 10.23.58.png

piotrr
Contributor

I'm not familiar with the last setting, but it seems to me that the last two settings conflict. 

See, "Trust Office 365 autodiscover redirects" is intended to automatically accept autodiscover redirections for Office 365 servers, but if you are also using a setting that replaces Office 365 with domain-based autodiscover, the former settings would be irrelevant. 

NB, I am on a fully cloud 365, not a hybrid, so my experience may not apply.