Team Viewer accessibility issue in Big Sur blank screen

CSD
New Contributor II

In BigSur when connecting to TeamViewer, operator see only background and top bar. We have a configuration Profile setup to grant full disk access and with scope All Computers and All Users (Grant Teamviewer Accessibility Rights), we do not get control user grants access, could you guide what might be the issue?
Things that are not automatically checked in SettingsSecurity & Privacy

AccessibilityTeamViewer Host
AccessibilityTeamViewer_Desktop (without it, operator cannot click)
Screen RecordingTeamViewer Host (without it, operator do not see what is happening on desktop)

7 REPLIES 7

geoff_widdowson
Contributor

@CSD The user has to tick Teamviewer in the Screen Recording, however Big Sur requires admin rights to do this, but Jamf PPPC can override that. Below is my PPPC for Big Sur.

cb63de27ff1b45eb9160131dfb027149

CSD
New Contributor II

Hi Geoff, thanks for your response, some how I don't see an option to add App or Service is greyed out, any thing missing here?
520484a8ce89428fa6e5c0ce32b276f0

mickl089
Contributor

After rollout this config file, the screen is still blank. The user has still to check the rights for screen. Only a password is not needed anymore...

geoff_widdowson
Contributor

@mickl089 That's by Apple's design. The user will always have to grant rights. Apple do not want IT or anyone else to be able to control Macs without the user granting rights first. This is the same for any application that uses the screen recording option.

mickl089
Contributor

Yeah, thank you @geoff.widdowson i know. But this config profile is then for me useless, because we can´t see anything at the first connection with TeamViewer like before. I think there is no need for this then 😞

geoff_widdowson
Contributor

@mickl089 but if you don't use it, then the user will never be able to grant you rights when you need to remote on, as Big Sur by default only lets admin users enable Screen Recording.

geoff_widdowson
Contributor

@CSD the 'Add' should only be greyed out when not in edit mode. On the PPPC payload page you have the '' in the top right to add a new 'App Access' and to add new 'App or Service' you use the ' Add' button on bottom right.