Trend Micro Package won't keep server information

New Contributor

I have a Trend Micro package that I downloaded from our Trend Micro server that I am trying to install as a policy after enrollment in Jamf. Trend Micro installs but when I try to check the server information it isn't there. The Parent Server line says something about there being no server information. I am also installing two other packages at the same time. The two other packages install and work just fine.

The Trend Micro version is 3.0.

If I take Trend out of this install package and just install it separately it will keep the server information just fine and update as it is supposed to.

I also tried creating a script file using some script examples I found on Jamf Nation, instead of the pkg file, but still no luck.

I am wondering if anyone else has run into this problem and if they have found a resolution.


Valued Contributor

After installing the Trend Micro Security 3.0.1098 client, it will attempt to connect to the parent server(s) and typically will do a pattern update.

If it's not able to locate/connect to a parent server, the client Menu Bar will display that it hasn't registered with any parent. But your not seeing that error.

When you open the TMS application and click on the lower center box "Smart Scan Agent Patter", it should show the parent server path and the component version numbers.

Are the two other packages related to networking, DNS, proxy, or firewall settings?


I just did this a few weeks ago with the OfficeScan 3.0.1098 installer. To get it to work, I used Composer to make a .pkg file that installs the original tmsminstaller.pkg and the Resources directory (with plists, etc) to /var/tmp/Trend. Then, a simple bash script that runs

installer -pkg /private/var/tmp/Trend30/tmsminstall.pkg -target / -verbose
rm -rf /private/var/tmp/Trend30
exit 0

Contributor II

+1 for @KSchroeder

We are doing the same thing here with our deployment. I was flummoxed too when i tried to deploy the pkg. If you look at the installer logs it actually says "could not find Resources/plist etc."

Valued Contributor

You or your Trend admin should be able to obtain the mass deployment "mpkg" for installing via Jamf Pro. (The server has an options for downloading single local installs via the pkg file or mass deployment via the mpkg file.)
Since the release of 3.0.x, I've switched to downloading the file from the console titled:

I rename it

and drop that into Casper Remote.
We've had good success with deploying via Casper Imaging and Casper Remote. They only issue we've seen is if the Trend Console Server isn't responding to new client connections. The result is that the clients will report that they have not successfully registered with a parent server. Restarting some of the services on the server will resolve that issue.


Hey @KSchroeder ,

Based on your example, is this how you structured your deployment:
When I try to open it locally on my machine, I get hit with the "The operation couldn’t be completed. ( error -1.)" error.