Unable to install profile "JSS Enrollment Profile"

Valued Contributor

I've just started to configure our few iPads and while my initial test about a month ago worked without any issues, I'm now running into a problem.

I'm using Apple Configurator to configure and enroll our iPads and have already downloaded and imported our JSS mobile config enrollment profile, the JSS trust profile, and configured the device enrollment payload w/ the MDM Server URL and JSS Built-in certificate authority certificate.

While the prepare process goes off initially without any issues, I run into problems toward the end when Configurator attempts to install the JSS Enrollment Profile. I get 2 errors when it attempts to install the enrollment profile. The Apple Configurator machine I'm using is on the same VLAN as our JSS and is able to get out to the Internet, so I'm confused as to why there's an error saying the connection appears to be offline ...


I tried redownloading and adding the enrollment profile, trust profile, and certificate but I'm still getting this same error.

Our network admin has made some firewall changes recently, but none of them have impacted the JSS or our clients from being able to communicate with one another. I'm just trying to figure out if this is potentially a network issue, or something else I'm not aware of.

JSS is on 9.73, Apple Configurator is 1.7.2


Contributor III

Hi @aporlebeke

The network connect needs to be on the device (in your case the iPad) to enrol the device.

What you'd need to do is add a wifi profile into the Apple Configurator deployment as well as your enrolment profile.

Give that a go and let us know if you make any progress



I get that error quite often from Configurator. I've also added a configuration profile in Configurator to automatically connect to our wireless, but for some reason it doesn't work on some devices. We just deployed about 140 iOS devices and a handful of devices experienced this error. We found that if you just continue through the setup assistant it will automatically connect to the wireless at the proper stage, then enroll the device as the last step of the setup assistant, so it doesn't appear to be detrimental to the deployment process, but it is a bit puzzling. If anyone else figures this on out, I'd like to know the fix as well.