Unable to remotely enroll machine


A machine lost connection to our JSS and I'm trying to re-enroll it. I've been able to re-enroll machines remotely that are on VPN with no issues in the past.

The machine:
- Was last enrolled over a month ago
- Resides where the time zone is 2 hours ahead

I've tried:
-remove framework
-install using Recon 9.97 (failed)
-ssh'd in and run sudo jamf enroll -prompt (failed)
-It fails checkJSSConnection

The error:
"Recon failed during the submit process..
Downlading CA Certificates... There was an error

Error enrolling computer: Unable to establish trust with the JSS - Connection failure. "The operation couldn't be completed. error 502"


New Contributor III

Are you on Linux by any chance? I just had the same problem, and it was because the certs were not copied over during the 9.97 upgrade.

See this for more info https://www.jamf.com/jamf-nation/discussions/22507/keystore-not-restored-when-upgrading-from-jss-9-96-to-9-97-on-linux

New Contributor III


Also tried copying the quickadd package and installing locally on the machine. Removed jamfframework, then tried to isntall using installer -pkg xxxxxxxx.pkg -target /

Received an "upgrade failed (installer encountered an error that caused the installation to fail. Contact the software manufacturer for assistance.)