Upgrade to v9.96 broke AD binding during imaging

Contributor III

Hi all

Just wondering if anyone else has had this issue. I upgraded from v9.93 to v9.96 yesterday and have discovered that machines are no longer able to bind to AD when imaged with Casper Imaging.

The username (username) and password provided for the domain (domainname) was not valid. (Attempt 1)
The username (username) and password provided for the domain (domainname) was not valid. (Attempt 2)
The username (username) and password provided for the domain (domainname) was not valid. (Attempt 3)

To resolve this, I had to re-enter the password for the join domain user in Casper Admin.

Hope this helps others!



Same here. Easy enough to fix but still annoying.

New Contributor

Same with us. Not a problem really but you have to wonder if it has knocked anything else that relies on authentication.

Contributor II

Us too.

New Contributor

WE also had the same problem.... however I realized I had not updated my Casper Imaging client on my netboot server.. now after that all I get is the Casper Imaging wallpaper on clients.. I am going backwards. :(

New Contributor II

Same here, typed the password into the directory binding page and saved it - all fixed.

Still amazes me how bugs like this appear. No big deal I suppose, but concerning for more important areas.


Valued Contributor

Adding a +1 to this. 9.92 -> 9.96

Valued Contributor II

us too.

New Contributor II

Us too 9.92 to 9.96

New Contributor

So i thought it was something I had done... I even went as far as created a new account to authenticate with.

Appears to be working now after putting in a new account. Being new to Casper (and Mac) this is scary, as these turn out to be "Great what did I do now!" moments.
Glad to see i am not the only one and that i was able to "figure" it out fairly quickly.

This may be the one downside of having a cloud solution that gets updated quickly and automatically...

New Contributor

I put the 9.92 client back on my image from my netboot server.. AD bind works and so does Casper imaging. Going to stick with that for now. I just wanted to post an update.

Contributor II

This probably goes without saying but this affects all directory bind objects, no matter where you are running them from.

Valued Contributor

Same here. Upgraded from 9.93 to 9.96. Re-enter the password used when binding resolved the issue.

Valued Contributor II

I ran into this upgrading my test environment from 9.81 to 9.96. Re-entering the bind user's password didn't help. Here is what I am seeing in the policy logs when i run our bind policy via Self Service:

An error occurred binding to Active Directory: dsconfigad: Credential verification failed because account is expired. (5302). (Attempt 1)

We use this exact account and password on our 9.81 production box without any issue. I tried creating a brand new bind config, and that didn't help either.

EDIT - also had to unlock my AD bind account in AD, as I imaged a Mac with binding before I re-entered the password. After re-enter of the password and unlock binding works again.

New Contributor III

+1 This hit us also, thank goodness for documentation! Had my heart racing for a few minutes.

Valued Contributor

+1 here as well. Luckily I had already read this thread and just had to re-enter the bind account password in the JSS.

Come on @JAMF are you testing these things at all?

New Contributor

+1 Just updated to 9.96 this weekend. This fixed it.