Upgrading to Monterey remotely and automatic


I created a policy which executes the following command 



'/Applications/Install macOS Monterey.app/Contents/Resources/startosinstall' --agreetolicense --nointeraction --forcequitapps



via the Files and Processes --> Execute Command field on Macs which are capable of Monterey and do have the installer downloaded.

Although the command is correct AND the Macs did the upgrade the logged result of the command is:



/bin/sh: /Applications/Install macOS Monterey.app/Contents/Resources/startosinstall: No such file or directory



Does anybody have an idea why?

It is misleading that the log shows "No such file or directory" although the command is run properly.


Contributor II

What happens if you change it to:


/Applications/Install\ macOS\ Monterey.app/Contents/Resources/startosinstall



Valued Contributor

Always drag your path into terminal and copy that output into your script/ exececute command. 

@bwoods You recommend this to get rid off formatted text, right?

Valued Contributor


I haven't tested that yet but I will. Thank you.

New Contributor II

I cannot execute any command :(, sorry you will have the command you use in the MDM.

I tested changing it but the error message is exactly the same.

Valued Contributor

try removing the single quotes from your path.

I did that like @AtillaTheC suggested but that did not help.

Valued Contributor

Are you dragging the startosinstall into terminal directly and then pasting the path into your script/command?

I did that, yes.

check a reply I made to another post with a working script


New Contributor II


New Contributor II

Not sure it helps your case but FYI I ran:

/Applications/Install\ macOS\ Monterey.app/Contents/Resources/startosinstall --agreetolicense --nointeraction --forcequitapps

remotely through ARD and it did work. Of course, the central requirement is that the installer app exist in that location in the first place. Not a direct answer, but maybe a workaround if it helps anyone.

New Contributor II

UPDATE (should have tried this first before posting). So I had to make a policy to copy the dmg/app to the correct location anyway since JAMF is much faster than ARD with the file size.  I tried making a "step 2" policy rigged to run after the 1st/copy that only did the exact cmd posted above, and success! Automatic updating underway.  Is it possible your cmd was just running before your actual copy completed or anything? Anyway, that got things working for me.