VPP Installs from SS

Release Candidate Programs Tester

Hey Team,

Running into a strange issue. For some reason I'm able to scope our VPP assignments to machines. But from the Self Service -- when you run the install it just stalls. When you run the install again, it fails. Once I restart the machine and log the user back in the apps start to install on their own and appear in the Apps folder.

I tried removing Config Profiles to see if that was the issue and nothing.

Basically I'm trying to have them install on demand.

Any ideas?



Release Candidate Programs Tester


Valued Contributor III

Not sure as to the cause of the issue, however it's worth noting that Self Service does nothing other than tell the device to attempt to download the app from the App Store. Normal behaviour for us is simply that the app starts downloading and the Self Service policy immediately says successful, regardless of the app then proceeds to install correctly.
I guess what I am saying is the issue is probably your VPP in general rather than Self Service, we have issues in our environment because we have authenticated proxy servers and occassionally VPP tries to start before this authentication is complete and basically ends up broken from that point on until a new user logs into the device.

New Contributor III

We had a similar issue trying to run the installs from the local admin account created on enrollment - Once we logged in as an MDM enabled user, the apps installed - Basically both the computer and the SelfService had to be logged in as one of or LDAP users, then it would install.

Release Candidate Programs Tester

@supson Yea, I actually have the VPP Scoped to my LDAP account for testing. The machine in JAMF is set to my user (and it targets any/all machines that are assigned to me) -- but regardless, Once I run the install from Self Service. It runs, then finishes and no application is listed until I actually log off and log back in then it installs on the machine. So weird.

New Contributor III

Sounds like a potential APNS issue, what happens if you automatically push this out instead of adding to Self Service? I’ve seen issues on certain networks where APNS commands/apps are not applied until a restart.

You could run the Push Diagnostic app to see if the Mac is receiving push notifications.