Wireless network issues post upgrading to Monterey

New Contributor

I'm hoping that someone else may have gone through the same workflow that I'm attempting to follow and may have some advice on how to solve this conundrum.


We have around 130 Intel Mac laptops and desktops in our environment, all are currently running Catalina. Unfortunately, we haven't been able to consider updating to Big Sur or Monterey until recently due to some issues with software compatibility, but now that those issues are resolved, we can finally start looking at migrating our Intel fleet to Monterey. We also recently migrated our users away from logging in with AD on-premise via Jamf Connect and Azure authentication, and as a part of that migration we deployed computer certificates with a WiFi profile for 802.1x authentication to our internal wireless network. Prior to the Jamf Connect and WiFi profile deployment, upgrading Catalina to Monterey was flawless, with the exception of the security software conflicts. After the Jamf Connect deployment, however, things have not gone as well.

The issue:

After upgrading an Intel Mac from Catalina to Monterey, the default WiFi GUI refuses to locate any wireless networks or connect to any existing saved networks. On occasion, the "Other Networks" option in the GUI will show 2-3 neighboring SSIDs, but refuses to connect to any of them.

What I've tried (so far):

The easiest thing I've found to do is to run the wireless diagnostics GUI. After clicking the first Continue button, within a few seconds WiFi bounces to life and connects right away to the saved corporate network. This is a somewhat messy solution, as it opens a Finder window after completing the diagnostics and may be complicated to explain to end-users that they don't really have to click all the way through the interface once WiFi is working again. I'd like to automate this process as much as possible so when the user upgrades, within a minute or two of the upgrade being complete their Mac just connects back to the network on its own.

The harder solution I've been working on for the past week has been creating a script that runs the wireless diagnostics via script after the first boot. I've created a script that generates a LaunchDaemon and companion script that self-destructs once WiFi is connected, and so far that works OK, but it still generates a lot of extra log files that aren't really needed and is going to prove troublesome if someone primarily uses Ethernet instead of WiFi on their device. I've tried a lot of the tricks on Google, including deleting the network preferences files and rebooting, disabling and re-enabling WiFi via ifconfig, creating a new network location and deleting the default, and many other variations of that.

So far, the *only* thing that seems to work every time is running the wireless diagnostics app, either through GUI or script. I did test removing the wireless / certificate profile from the device prior to upgrading, and that does resolve the issue, but there doesn't seem to be an easy way to automate that process. The really odd thing is that on an affected device, the GUI won't locate any wireless networks, and networksetup via Terminal can't connect to a saved network, but the airport service (via terminal) can scan and locate every wireless network within range without issue.


Would anyone have any suggestions on how to go about this in a different way? Am I going way down a path I probably shouldn't with the wireless diagnostics utility when there's a much easier method I could be using? Also, if anyone has an in-depth explanation about what exactly the wireless diagnostics utility is actually doing when it first runs, that'd be great info to have. Thanks in advance for any suggestions anyone may have.

Mike Moore
Lead System Administrator

New Contributor II

Thanks for posting this! We too had the same situation with ours after the upgrade and the Wifi Diagnostics GUI solved this..I even uninstalled our wifi config profile and reinstalled but did not fix. After the upgrade from 10.15 to Monterey 12.6 Wifi would not show any networks until we ran your suggested fix. I also tried another network location which didn't help either.  I noticed from MacOS 11 to 12, we saw no issues .