Xcode 10 VPP - Self Service not Installing

glaske
New Contributor III

Hi All,

We have been running into an issue with our Macs in Jamf that are attempting to install Xcode 10 from Self Service. It appears that it stays at 356kb even after a few hours of installation. Attempted within out corporate network and on a home network with the same result on multiple machines. All other VPP apps from Self Service are working with no issue. I understand it is a large install, but it should finish at some point if it was working properly.

Anyone else having issues deploying Xcode via VPP and Self Service?

Cheers,
Chris

23 REPLIES 23

DBrowning
Valued Contributor

I too noticed this. The App looks like it finished installing, but when you click to open, it just opens the App Store.

AVmcclint
Valued Contributor III

This is one reason why I decided to deploy Xcode by downloading it from developer.apple.com instead of the Mac App Store. Connecting to our internal distribution point 50 times is more reliable than downloading from Apple's servers 50 times. Processing the app for distribution is time consuming, but it works for me as long as we use the xcode deployment script (found in other discussions).

rcote
New Contributor

I am also having this same exact problem as well.

jkuo
Contributor

We're having this issue as well. Would love to find a fix!

jmariani
Contributor

Same issue here, hoping for a fix!

hkabik
Valued Contributor

Just verified I'm in this boat too. 😕

HamishEd
New Contributor II

Is there any word from Jamf on this? It's affecting us too and has become a serious issue, as one of our departments relies on Xcode heavily.

Stevie
Contributor

I can confirm that we are seeing this issue at our site and I was only able to install Xcode 10.x via setting the VPP to install Xcode Automatically. It worked only on 1 of the 5 computers after a restart. It never works if I try and install it via Self Service.

We have also reported to Jamf Support that our DEP is also broken since the Jamf Cloud was upgraded to 10.8.0

806a26a61797465fb7d670075240a02b

From our point of view the last two releases have been nothing but problems, very buggy and poor quality control.

ardrake
New Contributor III

I am also experiencing this issue, Jamf Pro 10.8.

HamishEd
New Contributor II

Still seeing this on Jamf Pro 10.9 with Xcode 10.1. Getting to be a bit of a pain.

glaske
New Contributor III

Thanks for the responses all - still seeing this issue as well. 10.9 and Xcode...

donmontalvo
Esteemed Contributor II

VPP + Self Service = boiling a pot of water

--
https://donmontalvo.com

donmontalvo
Esteemed Contributor II

Dylan_YYC
Contributor III

Ill toss my hat in here too. Seeing this issue with 10.9 and VPP, macos 10.13.6 & 10.14.4 Beta.
i did get some limited sucess for 2 of my test computers after i disabled our on-prem cache server but then the problem came back. Ive been working with Apple and Jamf on this, nothing but spinning wheels as of yet.

I have also been able to duplicate this issue with other apps that are large in size, seems like apps under 1gb work somewhat reliably but over that limit you get the .appdownload file.

landon_Starr
Contributor

I've seen this issue from a myriad of VPP apps over the last 2 weeks, but the O365 apps are the most common.

pbowden
Contributor III

@landon_Starr check your crash logs (Console > System Reports) and see if storedownloadd is crashing during app install. See https://macadmins.software/mas for more info and the RADAR that’s tracking this issue.

nberanger
Contributor

Hey folks. Just stumbled across this thread. I have a ticket open with Jamf for this very issue. They were working with Apple to try and resolve it.

pbowden
Contributor III

@glaske @ddcdennisb @AVmcclint @rcote @jkuo @jmariani @HamishEd @Stevie @donmontalvo @Dylan_YYC @nberanger @ardrake The issue with storedownloadd crashing during MAS installs is fixed in 10.14.4 Beta 4 (18E205e). This is RADAR 47685116. Let me know if you still see problems after the update. For clarity, typical symptoms of this bug:
- Larger MAS apps like Xcode and Office fail to install and leave behind an .appdownload stub
- Needing to run multiple jamf recon commands to coerce apps to install
- MDMClientError:72 failed command seen in JSS

I've updated https://macadmins.software/mas with the latest info. The largest outstanding issue that I'm still tracking is the inability to update MAS apps through MDM when the user has the app perpetually open.

nberanger
Contributor

Thanks for the update @pbowden 🙂

glaske
New Contributor III

Great, thanks for the update @pbowden ! Really appreciate you following up and submitting the RADAR. Looking forward to testing this when I get some time.

Cheers.

mhegge
Contributor II

JAMF > VPP > XCode 11 > Installed via Policy (Self Service)

Secure wifi

Lots of bandwidth

Caching server on network

SLOW AS F! Took me the better part of 2 days to get Xcode installed on 25 Mac Book Airs (new)

Takes less time installing the entire Adobe CC 2019 via JAMF

Look
Valued Contributor III

@mhegge It was exactly the same on my personal macBook on a fairly fast home internet connection.
Other apps (Pages, Numbers, etc... all admittedly much smaller) updated with no issues, but it was a couple of days of stop starting before Xcode finally installed.
I'm not using it at the moment, so it was not an issue. But I just noticed every time I went to use the laptop Xcode was either still installing or had restarted downloading from scratch again.

nberanger
Contributor

@pbowden "The largest outstanding issue that I'm still tracking is the inability to update MAS apps through MDM when the user has the app perpetually open."

Any update on this? I am still finding plenty of users on older versions of MAS apps... ones that are supposed to be updating through Jamf.

Thanks!
Nathan