jamf won't upload Excel Document to devices

foeba-ma
New Contributor

I have used the documents tool to upload an Excel file to our managed iPads. I set the right group so that the file should be uploaded to every device we have.

I did this yesterday. When I checked in just now I saw that there was no upload to the devices. I took one iPad and checked it. No sign of the document anywhere.

The activity protocol of the device showed the following error message (in german):

"Die Mobile Device Management-Anfrage ist ungültig." wich translates to MDM request is void.

 

Any ideas here on how to solve this issue?

2 REPLIES 2

GregBobbett
New Contributor III

I tried to run a test with an Excel and a Word Doc file. Both failed with the same message "The MDM request is invalid.". It's my thought that these files aren't supported file types. I have done PDFs successfully in the past, but my attempts to push image files, Excel files and Word documents has not worked. 

I couldn't find a list of acceptable file types in the Jamf School documentation (In-House Content Distribution - Jamf School Documentation | Jamf) but the fact that they specifically mention PDFs leads me to believe that there are few (if any) other file types supported.

I'm hoping that a Jamf School engineer will see this and let us know for sure.

Good luck!

 

Greg Bobbett

Thanks for testing it. I couldn't try it usind a numbers or keynote "document" file to see if native Apple filetypes are supported. 

PDF files did work in the past.

 

Let's hope a developer shares his insights with us. Couldn't find any specifications in the online documentation.