Jamf Connect stopped automatically updating


Hi All,

We successfully deployed Jamf Connect with the onboarding help from Jamf.  We will deploy in full this summer.  We've been using Jamf Connect on about 20 faculty and student loaners in the meantime.

I also configured Jamf Connect to update automatically and it worked for a time.  The Deployed version is 2.19.0.  Most of our devices got that version, but it hasn't updated since.  Anyone have any ideas? 

I setup automatic updating in Settings -> Jamf Apps -> Jamf Connect.  I was unaware if I have to do anything additionally like download the app or do something in Patch Management.  My understanding was set it to automatically update and that's it.




New Contributor II

Hi @ralvarezOES please share if you find any solution for this. 

New Contributor

Yes please, I have an annoyingly few stragglers that the update is not pushing to including a device right infront of me. Ive tried everything short of wiping it to get it to work. 

New Contributor III

yeah, I just found out this week that both of my config profiles (license and settings) stopped updating at some point. 

The license was stuck at 2.6, and the settings were at 2.22. This is DESPITE both being set to autoupdate major and minor versions. 

I have the same problem. Its not updating and with Sonoma I get the black screen error. Did anyone get any solutions yet?

New Contributor II

@Jay_mahapatra for the black screen issue, i deployed Jamf connect 2.27.0 version which fixed the issue. Haven't updated the config profile though.