Jamf Connect - Wont verify Password

New Contributor II


I have a couple of Silicon chip macbooks running Big Sur & Jamf Connect 2.0.2 (The same error is happening on 2.1.3 also)

Jamf connect installs with the same configuration profiles i have running on "older" macbooks and works without any issues. Although when you try logging in with my office 365 details it will authenticate and then ask me to verify the password. When i verify i get the following error message:

"Login authentication failed, Reason: Could not verify the credentials because directory server does not support the request."

I am not sure where i can go with this, if you need me to post my config profiles then i can.



New Contributor II

I am also experiencing this issue on DEP enrollment after a reboot. M1 Macs only

New Contributor II

Did you manage to get anywhere with the issue? I have raised a ticket today with support.

New Contributor III
New Contributor III

I had exactly the same problem and the support suggested me to Revive the Firmware. I did Revive and Restore with Apple Configurator 2 and the problem was resolved.

See info from support below: It could be an issue with M1 Mac indeed and nothing with Jamf Connect but an M1 issue


Can we try to restore the M1 via configurator to repair the firmware and see if the issue happens again afterwards?

Have a good day! Regards,

New Contributor III

We're also experiencing this, and after contacting Jamf Support I received an answer telling me that it's a known issue that will resolved by an upcoming update from Apple.

New Contributor II

Thanks for getting back guys.

Support told me the same today and it worked.

Download Apple configurator onto 2nd Mac and connect to "broke" Mac with USBc cable
Put the "Broke" Mac into DFU mode
Revive via AC2
reboot back into DFU mode
Restore the OS via AC2

Tried this on 2 separate M1 MacBooks today and worked fine.