URGENT!! MAC (M1 with Monterey) having problem while connecting to JAMF connect in login screen

New Contributor

Hi Everyone - Need your help on urgent basis to resolve this issue. The laptop is brand new with M1 chip and having Monterey OS, while taking it out from the box after selecting region and language, JAMF connect page is coming and black page is reflecting. As a workaround we are resetting the MACs and issue is getting resolved.

Need a permanent fix.


Valued Contributor II

Very vague, answering the below questions would add insight for prospective troubleshooters.


What Version # of Jamf Connect ?


Deployment method, are you deploying a custom plist via Configuration profile or utilizing the Jamf Applications Configuration Profile Payload?


What identity provider are you using?


lastly, share your plist / configuration profile, of course with the unique identifiers hidden

Looking for a Jamf Managed Service Provider? Look no further than Rocketman

Virtual MacAdmins Monthly Meetup - First Friday, Every Month


deployment method - configuration profile


Config profile - can't share due to client restriction

Valued Contributor II

You're three versions behind. Have you tried deploying a Mac with the latest version installed? Also where did you create the profile? Jamf Pro or the configuration tool? 

Jamf Pro to create config profile.

are you suggesting to try with jamf connect 2.13 ?


What version of Monterey is the computer? I believe there was a bug on 12.3 (and maybe even 12.2), where if you were using Azure for authentication, and had 2-step auth (at least with DUO, which we use in my enviorment), then the 2-step screen was blank, and login could not complete. This was due to something Apple implimented on their side, and 12.4 fixed it. 

This isn't exactly what you're seeing, but I'd still suggest trying to update to 12.5 and see what behavior you get with Jamf Connect. Maybe this is some relic of that bug.