11.5.1 breaking Apple Silicon / Jamf connect?

New Contributor III

Hey all! 


Just updated my M1 Mac mini to 11.5.1. Everything installed just fine, however when it booted back up it could not connect to any network. When attempting to open an application it looks like Rosetta 2 was uninstalled from the machine. My attempts to install it failed since I couldn't connect to a network (only tried internal networks) I rebooted, then every time I attempted to login with Jamf connect it rebooted the computer (still no network connection, used local login). I booted through safe mode and I could get a network connection. Then the screen went pink and it rebooted to recovery. Attempting to reinstall now. Anyone seeing this on their end / know how to prevent rosetta from uninstalling during a software update?


For now I have set our update policy for the company to defer for 90 days. 


UPDATE - Attempted the same update on the M1 MacBook Pro. The same issue occurred. This time I attempted connecting to a hotspot. Still no network connection. Removed the JAMF connect login screen with the supplied script. Booted to safe mode, connected to our guest wifi, ran the rosetta installer, and all is now working again... Thanks for the suggestions. What a pain! Hopefully Apple can put out something to fix this in the next 90 days lol. 


Contributor II

Same as THIS I do believe.

Bug since 11.3.1, fixed in 11.5.0 and re-broken in 11.5.1.

Bit us as well.

Doing the following has helped resolve it on almost every M1 that we had that went to 11.3.1/11.4.0:

Boot the device into Safe Mode.

Start up your Mac in safe mode - Apple Support

Login with an account with local admin rights.

Connect to the internet.

Launch Terminal.

Run the following command:

/usr/sbin/softwareupdate --install-rosetta --agree-to-license

Thanks for the tips! 


I attempted to boot in safe mode however there is something with the Jamf connect login screen that causes it to just reboot. Won't allow me to login locally. 

UPDATE: reinstall did not resolve the issue either. Restoring this computer through apple configurator. Also going to the update on my M1 MacBook with a login hook to run rosetta installer. Maybe wishful thinking, but it could work. 


Any Security Software which need Rosetta? Like Defender atp ? Disable the Network filter before you update...

New Contributor III

Great thought on this! 

Valued Contributor

Pretty sure it is breaking NoMAD Login too.
Had 2 Macs now install the 11.5.1 update, and when they get to the login screen you cant type anything, so you cant log in. Waiting to see if another one goes wrong to try sending out an install Rosetta command, see if that fixes it. All I have done for now is remove the NoMAD login from the Macs, they are test ones so it doesn't matter about the login method.
This is not good if it happens in a classroom full of students.

Try kennys script and add a disable network filter stepp and add  Rosetta reinstall stepp.

GitHub - kennyb-222/NoMADLoAD_AppleStagedUpdates: Disable NoMAD Login AD only during staged macOS up...


I'm having this same issue. When I try to install rosetta from the command line, either in a Safe Boot or not, I get:

Package Authoring Error: 071-72767: Package reference com.apple.pkg.RosettaUpdateAuto is missing installKBytes attribute

Installing: 100.0%

Where it hangs. I wish I could just download the package somewhere else and deploy it myself!

New Contributor III

11.5.2 seems to have fixed the issue. 

Oddly there are no release notes on this one. 

Thank you for all the replies and help!


Try this its a best in best 

incase your rosetta software update command failed (sudo /usr/sbin/softwareupdate --install-rosetta --agree-to-license) the second condition will do download the pkg file and install it.

so no more fail.