Activation Lock bypass not working on Monterey


Anyone having issues with using the Activation Lock Bypass Code from Jamf on Monterey? I have three Macs now on Monterey that I can't unlock with the bypass code. Get an error saying: "The operation couldn't be completed. Your Apple ID or password is incorrect." Tried on a Mac running Big Sur and the bypass code from Jamf worked to activate the Mac. With the computer erased and activated I installed Monterey, enabled Activation Lock through Find My Mac, erased it through Recovery and tried to activate using the refreshed bypass key from Jamf - got the error again. So looks like it may be a Monterey issue?

I would expect the bypass key to work regardless of whatever Apple ID the Mac has been connected to so not sure why this check fails or is even made.



Activation Lock.png


Release Candidate Programs Tester

I had a similar experience also on Monterey, although I'm not convinced its OS specific as I was able to activate a different device with the bypass code also on Monterey.


Interestingly enough whenever I would boot to internet recovery and attempt to erase the device that I was having issues with instead of letting me erase it, the machine would loop right back to activation lock over and over. I reached out to support who referred me to Apple, but I wanted to check in w/JAMF first just incase because I knew Apple would likely direct me back to JAMF.


This page offers activation lock removal support upon providing documentation for those odd instances where it just seems like nothing is working removal or activation wise. After giving some purchase info and filling out a form, I had activation lock successfully disabled in about 3/4 days and was able to erase, update, and re-deploy.

New Contributor II

When you reached out to Apple did they resolve the issue?

Contributor III

Is this a T2 Macbook by any chance?

Similar to @glennu , I also saw an activation loop with bypass code failing (even locked me out from trying). I believe it came down to the way I was entering recovery. Try local restore via command + r as opposed to internet recovery.

It was literally the first activation bypass code that had ever worked for me, ever!!

Release Candidate Programs Tester

Will definitely try this next time, I hope there won't be one, but we both know there likely will be lol Odd because you'd think it would work anywhere, but if it works that's all I care about-thanks for the tip!