Adobe packages not installing randomly

jmercier
Contributor II

hi, we just moved to JAMC cloud with a local HTTPS DP on 2019 server windows.

Before with AFP and SMB, we did not have any troubles we have right now im about to explain. Nothing else changed in our network or anything else...

recreated all packages from Adobe
Zip manually all the packages before copying to our local DP HTTPS
Sync with jamfcloud

we have a policy installing 15 software. 8 Adobe and 7 others softwares a lot smaller

Randomly Adobe packages not installing on computers

example :

LABS01 to LABS10: so 10 computers

labs01 have illustrator and incopy not installing giving error
labs02 lightroom missing
labs 03 incopy missing
labs04 all perfect
labs05 dreamweaver and indesign missing

and so on...

is HTTPS reliable ?
we followed the whole procedure to create that HTTPS and its working fine at low usage
the server as a lot of ressources not an issue
network is GIG everywhere and 10GB on stack server

like i said, AFP and SMB beforce zero errors.

Tried installing those softwares by calling the policy on all 10 computers at a same time... even tried 5... still random errors.

tried caching adobe packages and after installing... looks like same results

next step is to try assigning computers to policy and run that policy with check in trigger

or create linux DP to check if not IIS causing problems...

thanks to all

2 REPLIES 2

skinford
Contributor

@jmercier Good morning,

It seems that we may be having the same issue.  I have rebuilt the Adobe packages at least 4 or 5 times.  I don't zip them beforehand, but let JAMF admin do that.  I have not been able to Cache or Install a room.  I have had a ticket into JAMF support for more than two months now.  When were on-prem there were no issues like this at all, and we set up the Casper-DP to address this issue and it is also without any good outcome.

Have you cracked it at all?  Have you been able to fix this issue from last year when you posted this message?  Any information would be greatly received.

Have a very great day today!

skinford
Contributor

@jmercier, were you able to resolve your issue?  We just did and it's not Adobe at all, it's the Apple OSX and Hardware.

Turns out the Apple ethernet card goes from a full 1G down to 100M when you're at the login screen unless someone is logged in and then it stays at a full 1G when logged in.

I found this script here that fixes the issue, it runs the caffeinate terminal command.
https://community.jamf.com/t5/jamf-pro/prevent-mac-from-sleeping-best-practise/td-p/188961

This is how I changed mine, just making 24 hours the default instead of the three hours they had set.  We install more packages and I just wanted to test to make sure they are awake for that time in case of other loads we throw at them.  You can add whatever time that you want in "$4" when running it up to 48 or anytime other than 24 hours.

 

#!/bin/sh

declare -i LIVE_TIME
LIVE_TIME=86400
if [[ "$4" -gt "0" ]] && [[ "$4" -lt "49" ]]; then
LIVE_TIME=$4*3600
fi
echo Machine will not sleep for $LIVE_TIME seconds.
( caffeinate -sid -t $LIVE_TIME ) &
disown
exit

 

I'm having no issues running Adobe or anything because the card doesn't sleep anymore if you run this first.

I've spoken to Jake from JAMF and he said he would ask to add as a possible future feature update.

Let me know if you use it and if it works for you also!

Have a very great day!