Any way to reset com.apple.dock.plist?

beeboo
Contributor

currently deploying dock via outset and dockutil.

i have a script that writes the apps to add to the dock and its set to run on login-once per user via outset.

this works as expected (tried on currently broken machine by created a second local account), however, in my tinkering with trying to remove the recent apps via "show-recents", i seemed to have broken not only the dock, but what it shows.

tried re-running the script via outset
tried adding currently working code to the broken machine
did reboots
made sure to kill cache and the dock
tried dockutil --remove all + other iterations

however, i end up getting the same error: File "/usr/local/bin/dockutil", line 370, in main if addItem(pl, real_add_path, replace_label, position, before_item, after_item, section, displayas, showas, arrangement, tile_type, label_name): File "/usr/local/bin/dockutil", line 545, in addItem for existing_dock_item in (pl[section]):
KeyError: 'persistent-apps'

Account is a standard account, however, i tried running it as a local admin and it doesnt work
usually get an error to the effect that the domain com.apple.dock.plist doesnt exist

while its not a huge issue since its only affects a small subset (potentially) of users, id still like to be able to script/code this so its not manual (fix and show recent)

Thanks!

0 REPLIES 0