Autopkgr (jssimporter) "Distribution Point Password Required"

New Contributor II

I am having an issue adding a distribution point to AutoPkgr.

1) I have entered all the info manually in the "JSSImporter" section of AutoPkgr for an smb connected DP.

2) I then verify that all the info is correct by going to Command K and checking there. I have also verify by looking at the autopkg plist

3) I save and close "JSSImporter" in AutoPkgr.

4) I then click on "JSSImporter" again and see that I again need to click on the "Connect" button in order to connect to the JSS.

5) After a green button appears it prompts me with a "Distribution Point Password Required" message.

6) If I enter the password I now have two DP's that show up in the 'Distribution Points" box. Although they really are both the same DP, just one has the smb info entered manually.

The issues seems to be:
1) The JSSImporter is not staying connected to the JSS. Unless the default action is to always reconnect when you open the "JSSImporter" option.

2) The prompting of the "Distribution Point Password Required" message when all the information has already been previously entered.

Trying to run a test recipe or two does not place a pkg on the distribution point.

Thanks for everyones help in advance!



I re-installed the JSS Importer this morning and found the same thing.

Remove the duplicate Distribution Point, Save and close.

Should work fine after that (did for me). Failing that remove both DP and Click Connect to re add it.

New Contributor II

@jamesandre I tried that as well but came up with the same issues. I do have it working now. Here is what I did:

I changed the password of the read/write account for the DP. Apparently the jssimporter doesn't like special characters? This might be a problem as it is required here.
I left the port field in jssimporter blank as that was causing problems as well. It is an optional setting anyway.

Probably will test more as far as the special characters issue.