Black screen on reboot after 10.9.2 upgrade

Valued Contributor III

We're seeing a very rare issue with some systems where they get a black screen on boot after upgrading to 10.9.2. We've tracked it down to something related to color profiles, which itself seems to be stored in the user's ByHost files.

Has anyone run into this issue? We're trying to come up with a good fix: we found worked on at least one system, but the steps are pretty painful.


New Contributor

I am seeing this with many of my machines that have been upgraded to 10.9.2. I haven't tried the steps in the link yet as most of these are student machines and I tell them that anytime they bring their computer in for repair, I don't guarantee they will have their data upon return of the laptop.

New Contributor

I've run to the issue a number of times with the 10.9.2 update, and have resolved it one of two ways.

Most are resolved by deleting the login window preference file:

And those that still exhibit the issue of booting to black screen and cursor need another file removed:

Both can be removed via single user mode.


Thank you Buffington, I had the same issue on a computer running 10.9.3 version. It just randomly stopped booting past trying to draw the login window. Removing these two files fixed mine.


I'm seeing an issue with 10.10.5 machines booting 824a973885fd4e938a9576f957b310a0
to a black screen with the Apple logo and a progress bar that only makes it about 50% and stops.
I've found that if I ssh in and check running processes for login, I can then: sudo kill -HUP x (where x is the process for "/System/Library/CoreServices/ console"
Once that pid is killed, the log in window appears and all appears to work fine - until the next reboot.

I'm also tried removing the /Library/Preferences/ file, but that hasn't resolved the issue. I do not have a /private/var/db/.AppleUpgrade file to remove.

I've tried to re-apply the combo updater but getting a message that the machine doesn't meet the criteria to apply the update - even though it was applied once before.

I've seen the issue on 27" iMacs and MB Pro systems iMacs and MBP's are 4K as well as older resolution, or MBP Retina or older resolution too.
All machines are bound to AD and it doesn't seem to matter if they're wired or wireless

Any thoughts or suggestions?