Boot Camp Second Partition Incorrect Format

New Contributor

When in casper admin in Configurations under Additional Partitions I have selected a second drive as NTFS but when the computer completes imaging that partition is coming up as Fat32 in Disk Utility and not NTFS. Any words of advice would be appreciated. Thanks,
Jon Bergeron


New Contributor III

Did you end up resolving this ?

I seem to having this problem now but never used to.


New Contributor II

Hi Guys,

Has there been any updates on this issue? We recently started seeing the exact same thing where we select the format as NTFS but it instead formats it as FAT32. We're running Casper 9.3 and OS X 10.9.2

Any insight would be appreciated.


New Contributor II

I found this too but assumed it was by design. If you assign a WinClone captured image to the partition it will apply that and in the process convert the partition to NTFS. Otherwise it remains as FAT32.

My assumption was that OSX (and therefore Casper Imaging) can't format to NTFS itself - note that you don't get NTFS as an option in Disk Utility. Again, that's just my conclusion, I could be wrong.


Contributor II

I too am interested in this. Same issue: leaves a FAT32 partition even though the configuration states NTFS. We image using SCCM in our environment and our WinPE boot media/process expects there to be a NTFS partition. We are using DISKPART from a command line to manually reformat to NTFS but on a hundred or so machines, it is too labor intensive.

New Contributor III

I'm having this problem now, with Casper Suite 9.92. If anyone has solved it without weird workarounds, please let me know.

Valued Contributor III

@Randydid Specifically for SCCM.
Put a BAT file on the FAT32 partition to convert it to NTFS (it has to have no prompts obviously so just make certain you actually want it there), then have the SCCM task sequence check for this file and run it if it finds it.
For example we always call our Windows partition "WINDOWS" and I use the following function to create the BAT file.

Write_FORMATC() {
echo "Writing format script to WINDOWS"
chmod 777 /Volumes/WINDOWS/FORMATC.BAT

New Contributor III

I figured out what our problem was... We were uploading the Winclone image through Casper Admin, which automatically zipped the file. We had to manually unzip it, then re-open Casper Admin so it could create a new BOM for that file, then add it to the partition normally. Then it worked.

Apparently Casper itself can't actually format an NTFS partition, so it needs the Winclone bits to do that. If it can't read the Winclone image, it can't format the partition correctly.