Byhost issue?

Not applicable

Howdy all,

OK, hopefully this is an easy one. Working on our new 10.5 image, and when we push out a fresh image to a test box (while netbooted), I can't get Software Update to stick (in the Off position) for any user (1
admin, 2 managed). Don't think it is a Byhost issue, because everything else Byhost related retains proper settings. Only the Software Update setting doesn't play nice.

Tried making a UE package from the admin user with Software Update set to off, and set it to Fill Existing Users. Pushed it out with a Byhost update and rebooted. Software update is On for all three
users.....opposite of what I was trying to do. Any ideas? Never saw this issue on 10.4.

Could it be permissions related? Been monkeying with User permissions on 10.5, including removing ACLs. I don't think so, because in the above test, I have tried with User, Group, and Everyone set to RWX for
all three existing users.

Bonus Question:

Anybody been tweaking users permissions for 10.5? With 10.4 we were able to chmod all users Everyone perms to "No Access" with no issues. With 10.5 it looks like Everyone needs to be set to Execute for
Byhost and Menu Bar prefs to take effect correctly. What works best for you........leave 'em as Apple set 'em, or something different?

Matt Corippo
Lindamood-Bell Learning Processes


Contributor III

Hi matt,

Need to make a script that will run after running the following command to update byhosts properly.

/usr/sbin/jamf fixByHostFiles -target '/Volumes/Macintosh HD'

Should be good to go after that.


Not applicable

Thanks Craig. Will give it a go.

Gotta this something different/broken since 10.5, or something else in your experience? I take it that clicking the Fix Byhost box in a local or remote session does not work (I had assumed it was
running jamf fixByHostFiles).....for everybody?

Thanks again,

P.S. Any takers on ACLs in the Users space and 10.5? Love 'em......hate 'em......don't care?

Contributor III

Some of the newer hardware started to use a UUID instead of the Mac address to generate ByHost files.

JAMF, added this little work around into the binary, not sure which exact version of 5.x, but you have to do it with the binary for this particular issue, hence the after scrtip. I'm not really sure if the box in the remote session works or not in the same way, but I assume it calls the same command on that machine so it should? Locally I don't think does work. It should fix it for every user account on the machine I believe. Perhaps someone else can clarify that.