Can't Added Printers via Casper Admin

New Contributor II

I get the following error message.

Please help.




Honored Contributor II
Honored Contributor II

Strange, this has always worked for me.

I'd try quitting Casper Admin and relaunching, trying it from a different computer, and double check there isn't another printer with the same name already in there.

Failing that you can always add it with an lpadmin script and policy.

New Contributor III

I had a similar problem when we switched to Xerox printers. For certain models of the Xerox printers I could not get them to install via Casper remote. I had to resort to creating scripts to install the printers for those certain Xerox models.

lpadmin -p KET-Xerox7845-216 -L '1st Floor' -E -v ipp://'99.999.99.123' -P /Library/Printers/PPDs/Contents/Resources/Xerox\ WorkCentre\ 7845.gz -o printer-is-shared=false -D "KET-Xerox7845-216

Valued Contributor II

Hey all,

Sometimes, this can happen if the max_allowed_packet size is set too small; some printers require a max packet size larger than the defaults (depending on your install, it can range from 2mb - 16mb) and, instead, require 256mb or 512mb to install properly.

If this is the case, it will usually throw an error in your JAMFSoftwareServer.log about a max_allowed_packet being too small.

This variable can be changed a couple of ways:

1) Using the JSS Database Utility then going to Change MySQL Settings. Change the Max Packet size there to either 256M or 512M, save, and restart MySQL.

2) If that option is greyed out in your JSS Database Utility, you'll need to edit your my.ini (for Windows) or my.cnf (Linux/Mac) file manually and look for the max_allowed_packet variable, change it from whatever it's at to either 256M or 512M, save, and restart the MySQL service.

After that, give it another try and see if the printer can be added through Casper Admin.

If you have trouble finding your my.ini/my.cnf file, please get in touch with your Technical Account Manager either by phone, by e-mailing, or by using the My Support section of JAMF Nation.

Amanda Wulff
JAMF Software Support

New Contributor

I had a similar issue and tried increasing the max_allowed_packet size but still no dice. In the end it was the location field had too many characters in it. The person who setup the printer originally put an essay about the location of the printer, once I deleted that it added fine.