casper admin 9.1 now asking for webDavReadUsername password ??

mbracco
Contributor

Hello,
i updated the mss to 9.1, then upgraded the 9.01 JDS to 9.1 with the installer. Waiting gracefully 15 min to get trust.
now when trying to sync the master distribution point to the JDS (i have only one) casper admin 9.1 asks for the webdavread user password to mount the share point.
What's wrong here ?

8 REPLIES 8

andyinindy
Contributor II

I had this happen in our testing. I ended up just changing the password for the webDavReadUsername via the htpasswd command. Again, not sure why this was necessary, but it worked.

--Andy

bajones
Contributor II

@andyinindy Would you mind elaborating on this solution? I've run into the same replication error as the OP.

andyinindy
Contributor II

@bajones

Yeah, it's probably not the correct fix (since the webDavReadUsername password is generated randomly, and you shouldn't be getting prompted to enter the credentials), but I just used the process outlined here:

http://httpd.apache.org/docs/2.2/programs/htpasswd.html

Basically, it's just:

htpasswd -n webdavreadusername

...followed by the password of your choosing. Again, this shouldn't be happening, and don't hold me responsible if this borks your setup. My arse is now covered.

Good luck,

--Andy

andyinindy
Contributor II

All:

I ran into this again when trying to get replication set up on our JDSes. I started getting prompted for the webdavread password after I changed the location of the CasperShare directory. I had to do this due to disk space limitations (the JDS installer puts everything on "/" but we need it on "/export"). All I did was symlink /export/shares to /usr/local/jds/; I then started getting prompted for a password when trying to use Casper Admin to replicate.

I am going to try to change the password using the htpasswd command referenced above. Hopefully it works; I will post results.

--Andy

stevewood
Honored Contributor II

@andyinindy you may not need to go to that trouble. Changing the password in the JSS for that user should replicate to your JDS. I changed the user name and the password on mine and it replicated to the JDS.

In the JSS if you go to the JDS you want to adjust, click on the Distribution tab and then edit the user/pass.

You can verify this was replicated to the JDS by checking .DAVlogin file that is at /usr/local/jds/shares.

Obviously, if all you want to do is change the password, I'd take a peek at that file, then do the change to make sure it took place.

andyinindy
Contributor II

@stevewood

I took your advice and changed the passwords from the web interface; no luck. Still couldn't mount the CasperShare. I also noticed that I didn't have a ".DAVlogin" file in my /export/shares directory. So, I used the following command to create it:

sudo htpasswd -c /export/shares/.DAVlogin webDavReadUsername

This change has allowed Casper Admin to mount the storage on my JDS for replication.

Again, really wish that the JDS installer was a bit smarter about specifying a location for the shares folder, and that it weren't necessary to manually change the webDavReadUsername password using the htpasswd command. But as long as it works... I don't care?

Thanks for the advice, Steve.

--Andy

Graves
New Contributor

Sorry to bring up an old thread, but I just had this same problem. I was working on migrating my JSS to a new server. After restoring the backup of the old server to the new server, but before making my new JSS the production server, I had updated all the JSS's and JDS's to 9.3. When the new JSS went live, I received the prompt to login when Casper Admin opened.

With the new JSS in production, I just ran the JDS installer again for each JDS, and then Casper Admin opened without issue. I hope this helps anyone else that has this issue.

Lucasder
New Contributor III

I was given this by support which worked.
Go to the JSS -> Computer Management -> JDS Instances -> [JDS name] -> Distribution page. Click Edit.

Regenerate passwords for each of the WebDAV users.

Put a 1 at the end of each of the WebDAV usernames. Click save.

Click Edit again, remove the 1, returning the WebDAV usernames to their original spelling.

Click save again.

Each of those saves regenerated the passwords for the WebDAV users. Now let's get the JDS to pull down these new names.

From CLI on the JDS box, run a "jamfds enroll" command followed by a "jamfds policy" - this will re-create the .DAVlogin file with current info from JSS, including the newly updated WebDAV user passwords.