Composer under 10.11.x

New Contributor III

Has anyone had issues running Composer under flavours of El Cap?

I am completely unable to launch Composer. It fires up briefly, requests admin creds to 'make changes' and then when supplied quits. Same for any user on the system.

I've killed everything in /Library/Application Supp and also Saved Application States, but no joy.

Limited logs point to possibly something possibly amiss with OS version detection, but nothing very helpful...

Any thoughts welcome.

12/01/2016 17:04:43.000 kernel[0]: hfs: mounted Recovery HD on device disk0s3
12/01/2016 17:04:43.850 mds[71]: (Volume.Normal:2464) volume:0x7f96fa817000 ********** Bootstrapped Creating a default store:0 SpotLoc:(null) SpotVerLoc:(null) occlude:0 /Volumes/Recovery HD
12/01/2016 17:04:43.896 fseventsd[55]: Logging disabled completely for device:1: /Volumes/Recovery HD
12/01/2016 17:04:43.910 sandboxd[231]: ([6638]) DesktopServicesH(6638) System Policy: deny file-write-mode /Volumes/Recovery HD/.Trashes/1572573163
12/01/2016 17:04:44.000 kernel[0]: Sandbox: kcm(6627) deny(1) file-read-metadata /Library/Application Support/CrashReporter/
12/01/2016 17:04:44.471 Composer[6629]: WARNING: The Gestalt selector gestaltSystemVersion is returning 10.9.2 instead of 10.11.2. This is not a bug in Gestalt -- it is a documented limitation. Use NSProcessInfo's operatingSystemVersion property to get correct system version number.
Call location:
12/01/2016 17:04:44.471 Composer[6629]: 0   CarbonCore                          0x00007fff8b179c9b ___Gestalt_SystemVersion_block_invoke + 113
12/01/2016 17:04:44.471 Composer[6629]: 1   libdispatch.dylib                   0x00007fff8bb1a33f _dispatch_client_callout + 8
12/01/2016 17:04:44.471 Composer[6629]: 2   libdispatch.dylib                   0x00007fff8bb1a237 dispatch_once_f + 67
12/01/2016 17:04:44.471 Composer[6629]: 3   CarbonCore                          0x00007fff8b105b47 _Gestalt_SystemVersion + 987
12/01/2016 17:04:44.471 Composer[6629]: 4   CarbonCore                          0x00007fff8b104ddb Gestalt + 139
12/01/2016 17:04:44.471 Composer[6629]: 5   JAMFCore                            0x000000010fa349ad -[JAMFOsInfo getSystemVersionMajor:minor:bugFix:] + 36
12/01/2016 17:04:44.471 Composer[6629]: 6   JAMFCore                            0x000000010fa3945c -[JAMFOutlineView checkOsVersion] + 99
12/01/2016 17:04:45.450 diagnosticd[149]: error evaluating process info - pid: 6629, puniqueid: 6629
12/01/2016 17:04:45.462[1]: ([6646]) Endpoint has been activated through legacy launch(3) APIs. Please switch to XPC or bootstrap_check_in():
12/01/2016 17:04:45.645 ReportCrash[6646]: Saved crash report for Composer[6629] version 9.81 (1) to /Library/Logs/DiagnosticReports/Composer_2016-01-12-170445_ukm055402.crash
12/01/2016 17:04:45.875 mdworker[6276]: (ImportBailout.Error:1325) Asked to exit for Diskarb
12/01/2016 17:04:45.875 mdworker[6275]: (ImportBailout.Error:1325) Asked to exit for Diskarb
12/01/2016 17:04:45.875 mdworker[6280]: (ImportBailout.Error:1325) Asked to exit for Diskarb
12/01/2016 17:04:45.876 mdworker[6568]: (ImportBailout.Error:1325) Asked to exit for Diskarb
12/01/2016 17:04:45.000 kernel[0]: hfs: unmount initiated on Recovery HD on device disk0s3
12/01/2016 17:04:45.941 deleted[1006]: normalizeUserMountpoint:736 volRoot failed for /Volumes/Recovery HD
12/01/2016 17:04:45.941 deleted[1006]: _validateVolume:758 unable to normalize volume: "/Volumes/Recovery HD", vol: (null)


No issues for me running 10.11.2. Have you trashed and reinstalled the app?

New Contributor III

Yep, multiple times, still no joy

Valued Contributor II

@danf_b what version of Composer are you using on 10.11.2? I'm using Composer 9.82 successfully on 10.11.2.

New Contributor III

Nope, still no joy even with 9.8.2

Valued Contributor II

@danf_b I'd suggest trying a different computer or a different account on the same computer. I do all my Composer work in a local admin account on a test machine and don't have any issues with it working normally.

New Contributor III

Thanks for the suggestion @mpermann. Where we have installations that are large and need to be careful that no other file changes are getting detected I do use a separate machine. However I still need to be able to run Composer on my regular laptop in order to analyse packages, make minor changes to scripts etc. and jumping to another machine (or worse carrying two with me) is just not practical.

Regards another user, I cannot launch under any user on the system (I think I mentioned this in OP).

Valued Contributor II

@danf_b are the accounts you're trying to launch Composer in AD accounts? If they are, I would suggest trying to create a local admin account on the system and see what happens in that account. It's also possible that there is something wrong with your computer's OS, that's why I suggested trying Composer on another test machine. Preferably an identical model computer with the same OS version just to eliminate any additional variables. Good luck.

New Contributor III

Both AD and local admin accounts. Works fine on other machines.

Honored Contributor

Have you attempted to clear our any Composer specific preferences. I'm not sure where they are all kept but I would look under for anything referencing jamf and/or composer:
/Library/Application Support
~/Library/Application Support

Rename the folders/files (or backup and delete) and see what happens.

New Contributor III

Yep, all of that has gone. Was first out the door...

I'm down to last ditch, watching fs_usage output as it crashes and looking for which files where last to be accessed before the crash occurs.

Valued Contributor II

@danf_b if it works normally on other machines with the same OS then it sounds like there must be something specific on your computer that is causing the issue. Maybe reinstalling the OS would resolve the issue. Otherwise you could always backup the computer with Time Machine and re-image it and restore your data from Time Machine. While it's nice to know what specifically is causing an issue, sometimes it's just faster and less trouble to re-image and restore the data. But I suppose that will depend upon how much stuff you have on your computer. If you do figure out what is causing it, post back. I'd be interested in knowing.

New Contributor III
that will depend upon how much stuff you have on your computer

Sadly simple answer is: "Too much to be starting a re-install today"

Thanks though. I'll post back when I find the gremlin